aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-tz/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-tz/APKBUILD')
-rw-r--r--main/py3-tz/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/main/py3-tz/APKBUILD b/main/py3-tz/APKBUILD
index 7f38c3353c5..f24592da9c8 100644
--- a/main/py3-tz/APKBUILD
+++ b/main/py3-tz/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-tz
-pkgver=2021.1
+pkgver=2024.1
pkgrel=1
pkgdesc="Python3 definitions of world timezone"
-url="http://pytz.sourceforge.net/"
+url="https://pythonhosted.org/pytz/"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/p/pytz/pytz-$pkgver.tar.gz"
builddir="$srcdir/pytz-$pkgver"
@@ -16,16 +17,20 @@ replaces="py-tz" # Backwards compatibility
provides="py-tz=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
cd pytz/tests
- python3 test_tzinfo.py
+ ../../.testenv/bin/python3 test_tzinfo.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="507e24e3c5c2c619d9f3c7f4c33d44d262e33656b07701d0db78f5d67b263ad845dccc4ff50e48c580b0f295cf97ed146af7b9259890a50bb6da4c82b70c439b pytz-2021.1.tar.gz"
+sha512sums="
+cc1e4c9b34c62791cea277a0ce188d975e62135cb15bccfb49dc1a9366c7697ead9c67956846699f18b90db4c66e6c5fe1a91a524d01ae821c0eaa613550ea74 pytz-2024.1.tar.gz
+"