aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-tz/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-tz/APKBUILD')
-rw-r--r--main/py3-tz/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/main/py3-tz/APKBUILD b/main/py3-tz/APKBUILD
index 1c38ea8c48e..f24592da9c8 100644
--- a/main/py3-tz/APKBUILD
+++ b/main/py3-tz/APKBUILD
@@ -1,32 +1,36 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-tz
-_pkgname=pytz
-pkgver=2020.5
-pkgrel=0
+pkgver=2024.1
+pkgrel=1
pkgdesc="Python3 definitions of world timezone"
-url="http://pytz.sourceforge.net/"
+url="https://pythonhosted.org/pytz/"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
-source="https://pypi.io/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/p/pytz/pytz-$pkgver.tar.gz"
+builddir="$srcdir/pytz-$pkgver"
replaces="py-tz" # Backwards compatibility
provides="py-tz=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
cd pytz/tests
- python3 test_tzinfo.py
+ ../../.testenv/bin/python3 test_tzinfo.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="0845c0b7cefb8732e3016568b17ae73232fe6537bac6da89cb1bf911ba5786ee1be6b5e3aa8767225291e3a7e9afd5b8e40e4051671a3a006f9e2f71c551e13e pytz-2020.5.tar.gz"
+sha512sums="
+cc1e4c9b34c62791cea277a0ce188d975e62135cb15bccfb49dc1a9366c7697ead9c67956846699f18b90db4c66e6c5fe1a91a524d01ae821c0eaa613550ea74 pytz-2024.1.tar.gz
+"