aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-wheel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-wheel/APKBUILD')
-rw-r--r--main/py3-wheel/APKBUILD50
1 files changed, 33 insertions, 17 deletions
diff --git a/main/py3-wheel/APKBUILD b/main/py3-wheel/APKBUILD
index a325d68226a..adf2df19127 100644
--- a/main/py3-wheel/APKBUILD
+++ b/main/py3-wheel/APKBUILD
@@ -1,33 +1,49 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Peter Shkenev <santurysim@gmail.com>
pkgname=py3-wheel
-_pyname=wheel
-pkgver=0.36.2
-pkgrel=3
+pkgver=0.42.0
+pkgrel=1
pkgdesc="built-package format for Python"
-options="!check" # Testsuite fails
url="https://github.com/pypa/wheel"
arch="noarch"
license="MIT"
-subpackages="$pkgname-doc"
depends="python3 py3-packaging"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz
+makedepends="
+ py3-flit-core
+ py3-gpep517
+ "
+checkdepends="py3-pytest py3-setuptools python3-dev"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/w/wheel/wheel-$pkgver.tar.gz
use-system-packaging.patch
"
-builddir="$srcdir"/$_pyname-$pkgver
+builddir="$srcdir"/wheel-$pkgver
+options="!check" # circular with pytest
+
+prepare() {
+ default_prepare
-build() {
rm -rf src/wheel/vendored
+}
- python3 setup.py build
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 setup.py install
+ test-env/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- install -Dm 0644 "$srcdir"/$_pyname-$pkgver/docs/index.rst "$pkgdir/usr/share/doc/py3-wheel"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="73f5c6e77b8c396163b02e12ce7291e32960d771c732d8e97476971201b29e654d53551b2ce17db1fbde5697ced1908607995cac38fe2b61c63aec6abd4b6aaf wheel-0.36.2.tar.gz
-e20281a6fd42cf6dd24be9edf6b469cc7da0c03012127f5224a03c7cd40c785a8f7ae8e4c9829b590e5ca1242300224dcb7c3e571a9347736608512065a27065 use-system-packaging.patch"
+
+sha512sums="
+4816261c0f6d8971a80665f66868ec9cb082f2189b6e31e083a0d3a6080e159f06a4152f44eda1147a2b907b5aead0f63bbac725aacb56bb8be13fc77da2b79c wheel-0.42.0.tar.gz
+ce2081deefbbddf020a6e3fa4be7eed57f8cc53103fb4c7aa0fe2d129482d040df6b246768832979237f755d7af6f7779db085bc2c5d1485b25ffb26d302898e use-system-packaging.patch
+"