aboutsummaryrefslogtreecommitdiffstats
path: root/main/python3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/python3/APKBUILD')
-rw-r--r--main/python3/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index 85409ce1cef..66fc72a5cf9 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -3,7 +3,7 @@
pkgname=python3
# the python3-tkinter's pkgver needs to be synchronized with this.
-pkgver=3.8.10
+pkgver=3.8.15
_bluez_ver=5.54
_basever="${pkgver%.*}"
pkgrel=0
@@ -125,6 +125,7 @@ EOF
fail="$fail test_runpy" # fails on x86_64
fail="$fail test_threading" # hangs on all arches (except x86_64?)
fail="$fail test_asyncio" # hangs; routinely problematic (e.g. bpo-39101, bpo-41891, bpo-42183)
+ fail="$fail test_minidom" # we fixed expat cves via backports, this thinks it's newer and fails
# kernel related
fail="$fail test_fcntl" # wants DNOTIFY, we don't have it
@@ -184,9 +185,11 @@ wininst() {
"$subpkgdir"/usr/lib/python$_basever/distutils/command
}
-sha512sums="0be69705483ff9692e12048a96180e586f9d84c8d53066629f7fb2389585eb75c0f3506bb8182936e322508f58b71f4d8c6dfebbab9049b31b49da11d3b98e80 Python-3.8.10.tar.xz
+sha512sums="
+4fb3827b13c2452faa75e5ed18dddf381e80b4fffcfde046e289b4629cff0bb87fba1d09916b9b8a6f8039dc422c952293ebdb381c49f8ca7e7893ae4be6c28d Python-3.8.15.tar.xz
e19d15d3a478a7af47c1921c8827843492e38787b1182152155bd3d8ad9e1d8ee25c5fda1f24e38c54ebbf946b09fe75007dca9a24d1c35f73303558e558dcbe bluez-5.54.tar.xz
37b6ee5d0d5de43799316aa111423ba5a666c17dc7f81b04c330f59c1d1565540eac4c585abe2199bbed52ebe7426001edb1c53bd0a17486a2a8e052d0f494ad fix-xattrs-glibc.patch
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
d489b5d5f374e2b298954a2388771e500c6cf9b274012e06b3e71a34aa85c354369b3fa2a37c3121808075c1f1f340a9fa097996c149399e10b9424170211d90 custom-bluetooth-h-path.patch
-a84483246e413650a904c34c18f5e4f4168c39067d069f48557c330de6eb3db19fd96a4d453d742db3dcb7c7f962722903f62823c752ff90510c89830435ffc0 arm-alignment.patch"
+a84483246e413650a904c34c18f5e4f4168c39067d069f48557c330de6eb3db19fd96a4d453d742db3dcb7c7f962722903f62823c752ff90510c89830435ffc0 arm-alignment.patch
+"