aboutsummaryrefslogtreecommitdiffstats
path: root/main/python3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/python3/APKBUILD')
-rw-r--r--main/python3/APKBUILD218
1 files changed, 130 insertions, 88 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index 5d55ebab4df..6d580da114b 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -1,34 +1,60 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Sheila Aman <sheila@vulpine.house>
-
pkgname=python3
# the python3-tkinter's pkgver needs to be synchronized with this.
-pkgver=3.9.7
-_bluez_ver=5.55
+pkgver=3.12.3
_basever="${pkgver%.*}"
-pkgrel=4
-pkgdesc="A high-level scripting language"
+pkgrel=1
+pkgdesc="High-level scripting language"
url="https://www.python.org/"
arch="all"
license="PSF-2.0"
-subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-tests::noarch"
-makedepends="expat-dev openssl1.1-compat-dev zlib-dev ncurses-dev bzip2-dev xz-dev
- sqlite-dev libffi-dev tcl-dev linux-headers gdbm-dev>=1.18.1-r0 readline-dev
- mpdecimal-dev automake autoconf libtool autoconf-archive !gettext-dev"
+# pyc0 comes last because the files are named without a unique substring
+subpackages="
+ $pkgname-dbg
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-tests::noarch
+ $pkgname-pyc:_default_pyc
+ $pkgname-pycache-pyc2
+ $pkgname-pycache-pyc1
+ $pkgname-pycache-pyc0
+ $pkgname-gdbm
+ pyc:_pyc_meta:noarch
+ "
+depends="libssl3>=3.3.0"
+makedepends="
+ !gettext-dev
+ bluez-headers
+ bzip2-dev
+ expat-dev
+ gdbm-dev
+ libffi-dev
+ linux-headers
+ mpdecimal-dev
+ musl-libintl
+ ncurses-dev
+ openssl-dev
+ readline-dev
+ sqlite-dev
+ tcl-dev
+ xz-dev
+ zlib-dev
+ "
source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
- https://www.kernel.org/pub/linux/bluetooth/bluez-$_bluez_ver.tar.xz
- fix-xattrs-glibc.patch
+ externally-managed
musl-find_library.patch
- custom-bluetooth-h-path.patch
- arm-alignment.patch
- mpdecimal-2.5.1.patch
- bpo-43112.patch
- gnu-fallback-soabi.patch
"
options="net" # Required for tests
builddir="$srcdir/Python-$pkgver"
# secfixes:
+# 3.11.5-r0:
+# - CVE-2023-40217
+# 3.11.1-r0:
+# - CVE-2022-45061
+# 3.10.5-r0:
+# - CVE-2015-20107
# 3.9.5-r0:
# - CVE-2021-29921
# 3.9.4-r0:
@@ -50,32 +76,41 @@ builddir="$srcdir/Python-$pkgver"
# 3.6.8-r1:
# - CVE-2019-5010
+# was briefly present, and is in 3.16
+provides="pythonispython3=$pkgver-r$pkgrel"
+
prepare() {
default_prepare
# force system libs
- rm -r Modules/expat \
- Modules/_ctypes/darwin* \
- Modules/_ctypes/libffi*
-
- mv "$srcdir"/bluez-$_bluez_ver/lib "$srcdir"/bluez-$_bluez_ver/bluetooth
+ rm -r Modules/expat
+}
- # Speed up LTO
- sed -i -e "s|-flto |-flto=4 |g" configure configure.ac
+build() {
+ # set thread stack size to 2MB so we don't segfault before we hit
+ # sys.getrecursionlimit()
+ # note: raised from 1 as we ran into some stack limit on x86_64 too
+ # sometimes, but not recursion
+ local stacksize=0x200000
- autoreconf -fi
+ # we want -O2 here for more speed for such a large interpreter.
+ export CFLAGS_NODIST="$CFLAGS -O2 -DTHREAD_STACK_SIZE=$stacksize"
+ export CXXFLAGS_NODIST="$CXXFLAGS -O2"
+ export LDFLAGS_NODIST="$LDFLAGS"
- sed "s|@bluetoothdir@|\"$srcdir/bluez-$_bluez_ver\"|g" -i setup.py
-}
+ case "$CARCH" in
+ ppc64le)
+ # FIXME: on ppc64le, the stack-clash-protection from gcc seems to segfault
+ # python.. sometimes. not sure if python or gcc bug (probably former)
+ # for an easy reproduction, run the testsuite of community/py3-lmdb
+ export CFLAGS_NODIST="${CFLAGS_NODIST/-fstack-clash-protection}"
+ export CXXFLAGS_NODIST="${CXXFLAGS_NODIST/-fstack-clash-protection}"
+ ;;
+ esac
-build() {
- # -Os overwrites --enable-optimizations
- export CFLAGS="${CFLAGS/-Os/} -fno-semantic-interposition"
- export LDFLAGS="$LDFLAGS -fno-semantic-interposition"
+ # we set them via NODIST to not propagate them and duplicate them to modules
+ unset LDFLAGS CFLAGS CXXFLAGS CPPFLAGS
- # Include bluez headers. Python only needs bluetooth/bluetoot.h and doesn't
- # link against bluez. Depending on bluez-dev introduces a circular dep:
- # Python -> bluez -> glib -> meson -> python
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -88,19 +123,10 @@ build() {
--with-computed-gotos \
--with-dbmliborder=gdbm:ndbm \
--with-system-expat \
- --with-system-ffi \
--with-system-libmpdec \
- --without-ensurepip \
- --with-bluetoothdir="$srcdir/bluez-$_bluez_ver"
+ --without-ensurepip
- # set thread stack size to 1MB so we don't segfault before we hit
- # sys.getrecursionlimit()
- # s390x needs more stack space due to its calling convention
- local stacksize=0x100000
- case "$CARCH" in
- s390x) stacksize=0x200000;;
- esac
- make EXTRA_CFLAGS="$CFLAGS -DTHREAD_STACK_SIZE=$stacksize"
+ make
}
check() {
@@ -123,39 +149,23 @@ EOF
local fail
# musl related
- fail="test__locale test_locale test_strptime test_re" # various musl locale deficiencies
+ fail="test__locale" # various musl locale deficiencies
+ fail="$fail test_locale"
+ fail="$fail test_re"
fail="$fail test_c_locale_coercion"
fail="$fail test_datetime" # hangs if 'tzdata' installed
fail="$fail test_os" # fpathconf, ttyname errno values
- fail="$fail test_posix" # sched_[gs]etscheduler not impl
- fail="$fail test_shutil" # lchmod, requires real unzip
# FIXME: failures needing investigation
- fail="$fail test_faulthandler test_gdb" # hangs(?)
- fail="$fail test_tokenize test_tools" # SLOW (~60s)
- fail="$fail test_capi" # test.test_capi.EmbeddingTests
- fail="$fail test_threadsignals" # test_{,r}lock_acquire_interruption
- fail="$fail test_time" # strftime/strptime %Z related
- fail="$fail test_cmath test_math" # hang(?) on x86
- fail="$fail test_hash test_plistlib" # fail on armhf
fail="$fail test_ctypes" # fail on aarch64 (ctypes.test.test_win32.Structures)
- fail="$fail test_cmd_line_script" # fails on x86_64
- fail="$fail test_multiprocessing_main_handling" # fails on x86_64
- fail="$fail test_runpy" # fails on x86_64
- fail="$fail test_threading" # hangs on all arches (except x86_64?)
- fail="$fail test_selectors" # AssertionError: 'Python' not found in '' (python3.9)
- fail="$fail test_nntplib"
- fail="$fail test_asyncio" # hangs; routinely problematic (e.g. bpo-39101, bpo-41891, bpo-42183)
# kernel related
fail="$fail test_fcntl" # wants DNOTIFY, we don't have it
- # just a single subtest test_memoryview_struct_module is breaking on pc64le.
- if [ "$CARCH" = "ppc64le" ]; then
- fail="$fail test_buffer" # fail on ppc64le
- fi
+ # test_clock_settime returns Function not implemented instead of the
+ # expected permission error in docker (CI). Disable for now.
case "$CARCH" in
- mips64) fail="$fail test_compileall" ;; # FIXME: crashes on octeon3
+ ppc64le) fail="$fail test_time";;
esac
make quicktest TESTOPTS="-j${JOBS:-$(nproc)} --exclude $fail"
@@ -164,16 +174,16 @@ EOF
package() {
make -j1 DESTDIR="$pkgdir" EXTRA_CFLAGS="$CFLAGS" install maninstall
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ install -Dm644 "$srcdir"/externally-managed \
+ "$pkgdir"/usr/lib/python$_basever/EXTERNALLY-MANAGED
+
# those are provided by python3-tkinter
rm -r "$pkgdir"/usr/bin/idle* "$pkgdir"/usr/lib/python*/idlelib \
"$pkgdir"/usr/lib/python*/tkinter
- # TODO(Leo): some stuff still wants /usr/bin/python to be python2
- # which is a bummer because they are holding back progress but they
- # are important enough that we need to do it
- #
- # Python3 is the canonical python for the moment
- # ln -s /usr/bin/python3 "$pkgdir"/usr/bin/python
+ ln -s python3 "$pkgdir"/usr/bin/python
+ ln -s python3-config "$pkgdir"/usr/bin/python-config
}
dev() {
@@ -188,24 +198,56 @@ dev() {
tests() {
pkgdesc="The test modules from the main python package"
- cd "$pkgdir"/usr/lib/python$_basever
- local i; for i in */test */tests; do
- mkdir -p "$subpkgdir"/usr/lib/python$_basever/"$i"
- mv "$i"/* "$subpkgdir"/usr/lib/python$_basever/"$i"
- rm -rf "$i"
- done
- mv "$pkgdir"/usr/lib/python$_basever/test \
- "$subpkgdir"/usr/lib/python$_basever/
+ amove usr/lib/python$_basever/test
+}
+
+gdbm() {
+ pkgdesc="Python backend for GNU gdbm"
+
+ amove usr/lib/python3*/lib-dynload/_gdbm.cpython*
+}
+
+_pyc_meta() {
+ pkgdesc="Meta package for pulling in all -pyc packages"
+ depends=""
+ mkdir -p "$subpkgdir"
+}
+
+# python3-pyc, to install pyc by default
+_default_pyc() {
+ pkgdesc="$pkgdesc (install .pyc cache files)"
+ install_if="$pkgname=$pkgver-r$pkgrel"
+ depends="
+ $pkgname-pycache-pyc0=$pkgver-r$pkgrel
+ pyc
+ "
+
+ mkdir -p "$subpkgdir"
+}
+
+pyc0() {
+ pkgdesc="$pkgdesc (.pyc pycache files)"
+
+ cd "$pkgdir"
+ amove $(find usr/lib/python3* -name "*.pyc")
+}
+
+pyc1() {
+ pkgdesc="$pkgdesc (.opt-1.pyc pycache files)"
+
+ cd "$pkgdir"
+ amove $(find usr/lib/python3* -name "*.opt-1.pyc")
+}
+
+pyc2() {
+ pkgdesc="$pkgdesc (.opt-2.pyc pycache files)"
+
+ cd "$pkgdir"
+ amove $(find usr/lib/python3* -name "*.opt-2.pyc")
}
sha512sums="
-55139776ab58a40f9e1e70613d7071d559ef9e51e32a77791422aac134322c21a49f0348c42813214b69789c589367eae43e16d4ae838a73daf37617e966b735 Python-3.9.7.tar.xz
-9423cb60d15a6f068838497a1eaea9f5a32d70c07191c313ba821a6919d6e0c436ada4f547cc5f2db5eacc0123429ad54851f57df2554f61fa293743ec14a033 bluez-5.55.tar.xz
-fe123dd871f7a3fa868c499a957b94f1d815a1e1de964aaff1116c579defd4d9d1e9b7eb418cf114b169b97426ed603bf4b1e61b45ec483df06abe988c6a30ee fix-xattrs-glibc.patch
+4a2213b108e7f1f1525baa8348e68b2a2336d925e60d0a59f0225fc470768a2c8031edafc0b8243f94dbae18afda335ee5adf2785328c2218fd64cbb439f13a4 Python-3.12.3.tar.xz
+46dd8230ee2ab66e9c4157c10b2bd9c414fd7f30be0bee73e21a9eea88f63fff362d47828e0fc77ddc59df097b414b21505f8b5f98bc866381115c58ae3f4862 externally-managed
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
-6b04a779f0aaf243d398fe28207a7257d74e6fb0487b05fbb6bf56d4f1b842714f51fcb4953214b25c7552d688e8b98d2ef63ef6c29ebed194b9a80870db2d98 custom-bluetooth-h-path.patch
-a84483246e413650a904c34c18f5e4f4168c39067d069f48557c330de6eb3db19fd96a4d453d742db3dcb7c7f962722903f62823c752ff90510c89830435ffc0 arm-alignment.patch
-d95e36ef3c315a2ddf689c9319e027cf56e8817b0cae139e3ade4742ab6f9efcb3cc4adca178e9bbc8757bd0e3fb924ac2b37e66e70eaa7288202a25339eed7d mpdecimal-2.5.1.patch
-68a3b0bc270e4f7ec8593945c8c891fab988489f4ba9ee78a0e4351df0699db16dfad7d374f13758c80962b0cea048ff577c0462857cd13919d6cefa1f6a382f bpo-43112.patch
-7500d4e51975446fd59231985f75a198e8074b9f0a0941b7998958e8a4175de09bd08fd1b4db26aa82f9cef0db922078bf4a6f05e50abc37a200c5f6169e6868 gnu-fallback-soabi.patch
"