aboutsummaryrefslogtreecommitdiffstats
path: root/main/python3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/python3/APKBUILD')
-rw-r--r--main/python3/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index c529079107a..4210ff5aeb6 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -3,7 +3,7 @@
pkgname=python3
# the python2-tkinter's pkgver needs to be synchronized with this.
-pkgver=3.7.4
+pkgver=3.7.5
_basever="${pkgver%.*}"
pkgrel=0
pkgdesc="A high-level scripting language"
@@ -23,8 +23,10 @@ source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
builddir="$srcdir/Python-$pkgver"
# secfixes:
+# 3.7.5-r0:
+# - CVE-2019-16056
# 3.6.8-r1:
-# - CVE-2019-5010
+# - CVE-2019-5010
prepare() {
default_prepare
@@ -93,7 +95,7 @@ EOF
fail="$fail test_posix" # sched_[gs]etscheduler not impl
fail="$fail test_shutil" # lchmod, requires real unzip
- # failures needing investigation
+ # FIXME: failures needing investigation
fail="$fail test_faulthandler test_gdb" # hangs(?)
fail="$fail test_tokenize test_tools" # SLOW (~60s)
fail="$fail test_capi" # test.test_capi.EmbeddingTests
@@ -102,6 +104,9 @@ EOF
fail="$fail test_cmath test_math" # hang(?) on x86
fail="$fail test_hash test_plistlib" # fail on armhf
fail="$fail test_ctypes" # fail on aarch64 (ctypes.test.test_win32.Structures)
+ fail="$fail test_cmd_line_script" # fails on x86_64
+ fail="$fail test_multiprocessing_main_handling" # fails on x86_64
+ fail="$fail test_runpy" # fails on x86_64
# kernel related
fail="$fail test_fcntl" # wants DNOTIFY, we don't have it
@@ -114,10 +119,7 @@ EOF
s390x|ppc64le) fail="$fail test_threading" ;; # FIXME: hangs
esac
- # FIXME: tests that fail after openssl 1.1
- fail="$fail test_asyncio test_ssl"
-
- make quicktest TESTOPTS="--exclude $fail"
+ make quicktest TESTOPTS="-j${JOBS:-$(nproc)} --exclude $fail"
}
package() {
@@ -158,6 +160,6 @@ wininst() {
"$subpkgdir"/usr/lib/python$_basever/distutils/command
}
-sha512sums="71f64668c259f3ed07bd4aa239dbba6cc1b6b0a84d50bbff160664845d7986f757e4d65fca327e62a2d12ba593742ca83a22f7cb6093aff8715ec916c2ba9416 Python-3.7.4.tar.xz
+sha512sums="f4f3879881f260f58dbb041fb0f2f210d4b70b02a739e41e50e6fea67d31855a7a29ce4ebef66bfde3d0edf54b946a48f78490f986da965357b835d4dbb3f414 Python-3.7.5.tar.xz
37b6ee5d0d5de43799316aa111423ba5a666c17dc7f81b04c330f59c1d1565540eac4c585abe2199bbed52ebe7426001edb1c53bd0a17486a2a8e052d0f494ad fix-xattrs-glibc.patch
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch"