summaryrefslogtreecommitdiffstats
path: root/main/qemu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/qemu/APKBUILD')
-rw-r--r--main/qemu/APKBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index e1f694d5e49..7d4f56074b7 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
pkgver=0.13.0
-pkgrel=0
+pkgrel=1
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://www.nongnu.org/qemu/"
arch="x86 x86_64"
@@ -26,9 +26,10 @@ $pkgname-sh4eb
$pkgname-sparc
$pkgname-sparc64
$pkgname-x86_64
+$pkgname-img
"
source="http://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz
- kqemu.patch
+ 80-kvm.rules
"
prepare() {
@@ -42,7 +43,6 @@ prepare() {
Makefile Makefile.target tests/Makefile
sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
Makefile.target
-# patch -p1 -i ../kqemu.patch || return 1
}
build() {
@@ -61,6 +61,8 @@ build() {
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 "$srcdir"/80-kvm.rules \
+ "$pkgdir"/lib/udev/rules.d/80-kvm.rules
}
_subsys() {
@@ -87,5 +89,14 @@ sparc() { _subsys sparc; }
sparc64() { _subsys sparc64; }
x86_64() { _subsys x86_64; }
+img() {
+ pkgdesc="QEMU command line tool for manipulating disk images"
+ replaces="qemu"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/qemu-img \
+ "$pkgdir"/usr/bin/qemu-io \
+ "$subpkgdir"/usr/bin/
+}
+
md5sums="397a0d665da8ba9d3b9583629f3d6421 qemu-0.13.0.tar.gz
-f63f7412f016d8ccddabfd02ea28e748 kqemu.patch"
+66660f143235201249dc0648b39b86ee 80-kvm.rules"