aboutsummaryrefslogtreecommitdiffstats
path: root/main/rsync/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/rsync/APKBUILD')
-rw-r--r--main/rsync/APKBUILD47
1 files changed, 27 insertions, 20 deletions
diff --git a/main/rsync/APKBUILD b/main/rsync/APKBUILD
index 5529cd11996..a4adb4ef543 100644
--- a/main/rsync/APKBUILD
+++ b/main/rsync/APKBUILD
@@ -1,15 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rsync
-pkgver=3.2.3
-pkgrel=4
+pkgver=3.3.0
+pkgrel=0
pkgdesc="A file transfer program to keep remote files in sync"
url="https://rsync.samba.org/"
arch="all"
license="GPL-3.0-or-later"
-makedepends="perl acl-dev attr-dev popt-dev zlib-dev zstd-dev"
-subpackages="$pkgname-doc $pkgname-openrc rrsync"
+makedepends="
+ acl-dev
+ attr-dev
+ lz4-dev
+ perl
+ popt-dev
+ xxhash-dev
+ zlib-dev
+ zstd-dev
+ "
+subpackages="$pkgname-doc $pkgname-openrc rrsync::noarch"
source="https://download.samba.org/pub/rsync/rsync-$pkgver.tar.gz
- Fix-regression-with---delay-updates.patch
rsyncd.initd
rsyncd.confd
rsyncd.conf
@@ -17,14 +25,20 @@ source="https://download.samba.org/pub/rsync/rsync-$pkgver.tar.gz
"
# secfixes:
+# 3.2.4-r2:
+# - CVE-2022-29154
# 3.1.2-r7:
# - CVE-2017-16548
# - CVE-2017-17433
# - CVE-2017-17434
+# 0:
+# - CVE-2020-14387
# delete the itemize test because it is flawed and depends on filesystem-specific behavior
prepare() {
default_prepare
+ update_config_sub
+
rm testsuite/itemize.test
# Prevent the aports version being used
@@ -32,9 +46,7 @@ prepare() {
}
build() {
- # Force IPv6 enabled, upstream bug https://bugzilla.samba.org/show_bug.cgi?id=10715
- CFLAGS="$CFLAGS -DINET6" \
-
+ CFLAGS="$CFLAGS -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,15 +56,11 @@ build() {
--localstatedir=/var \
--enable-acl-support \
--enable-xattr-support \
+ --enable-xxhash \
--without-included-popt \
--without-included-zlib \
- --disable-lz4 \
- --disable-xxhash \
--disable-openssl
- # lz4, xxhash and openssl support were implicitly disabled before via automagic
- # since nobody complained that those features were missing starting with 3.2.x
- # they cause errors unless they are expilcitly disabled. If you need those
- # features then open a MR
+ # openssl is disabled since xxh checksums are faster anyway
make
}
@@ -67,20 +75,19 @@ package() {
install -Dm644 "$srcdir"/rsyncd.conf "$pkgdir"/etc/rsyncd.conf
install -Dm644 "$srcdir"/rsyncd.confd "$pkgdir"/etc/conf.d/rsyncd
install -Dm644 "$srcdir"/rsyncd.logrotate "$pkgdir"/etc/logrotate.d/rsyncd
+ install -Dm755 support/rrsync -t "$pkgdir"/usr/bin/
+ install -Dm644 rrsync.1 -t "$pkgdir"/usr/share/man/man1/
}
rrsync() {
pkgdesc="Restricted rsync, restricts rsync to a subdir declared in .ssh/authorized_keys"
- depends="rsync perl"
- arch="noarch"
+ depends="rsync python3"
- cd "$builddir"
- install -D -m 755 ./support/rrsync "$subpkgdir"/usr/bin/rrsync
+ amove usr/bin/rrsync
}
sha512sums="
-48b68491f3ef644dbbbfcaec5ab90a1028593e02d50367ce161fd9d3d0bd0a3628bc57c5e5dec4be3a1d213f784f879b8a8fcdfd789ba0f99837cba16e1ae70e rsync-3.2.3.tar.gz
-01a8560419e536c4987a6954b51d0751bce77e041f2d75157067156c0e197178e25e7a6b0ca29cca5d4474f5671ac36500079dba1ed1737cea18f1d663570321 Fix-regression-with---delay-updates.patch
+df5c53bc2f2b0e7e30f475903e5e4296dc2fbcf08e9ea6c3c61462d0e52b067c27e82deeb4be79102c86e9aa55a825182e126f22df44dabf5b7328acb2a01d10 rsync-3.3.0.tar.gz
b9bf1aa02f96e4294642ead5751bd529ca1267c08e83a16342fba5736c3a8ec89568feb11fb737e974cb1bee7e00e7a8898d25844892366c6167b9ea8d1e647c rsyncd.initd
d91337cfb57e6e3b2a8ba1e24f7d851dd927bfc327da2212b9eb0acda0e1ca2f24987f6dcc4903eccc3bf170e0f115172b3cfa5a172700495296f26302c834d7 rsyncd.confd
3db8a2b364fc89132af6143af90513deb6be3a78c8180d47c969e33cb5edde9db88aad27758a6911f93781e3c9846aeadc80fffc761c355d6a28358853156b62 rsyncd.conf