aboutsummaryrefslogtreecommitdiffstats
path: root/main/s6-portable-utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/s6-portable-utils/APKBUILD')
-rw-r--r--main/s6-portable-utils/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/main/s6-portable-utils/APKBUILD b/main/s6-portable-utils/APKBUILD
index 7cb3e9e088f..9803924b03d 100644
--- a/main/s6-portable-utils/APKBUILD
+++ b/main/s6-portable-utils/APKBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Laurent Bercot <ska-devel@skarnet.org>
# Contributor: John Regan <john@jrjrtech.com>
+# Maintainer: Laurent Bercot <ska-devel@skarnet.org>
pkgname=s6-portable-utils
-pkgver=2.2.3.3
-pkgrel=0
+pkgver=2.3.0.3
+pkgrel=1
pkgdesc="skarnet.org's tiny portable generic utilities"
-url="http://skarnet.org/software/$pkgname/"
+url=https://skarnet.org/software/s6-portable-utils/
arch="all"
license="ISC"
-makedepends="skalibs-dev>=2.11"
+makedepends="skalibs-dev>=2.14"
options="!check"
subpackages="$pkgname-doc"
source="https://skarnet.org/software/s6-portable-utils/s6-portable-utils-$pkgver.tar.gz"
@@ -18,12 +18,15 @@ build() {
--enable-static \
--disable-allstatic \
--prefix=/usr \
- --libdir=/usr/lib
+ --libdir=/usr/lib \
+ --enable-multicall
make
}
package() {
make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/include/s6-portable-utils/config.h
+ rmdir -p "$pkgdir"/usr/include/s6-portable-utils || :
}
doc() {
@@ -33,5 +36,5 @@ doc() {
}
sha512sums="
-f3f2e2f47ac61bad23e04a7e27cb833c21be610d54b50fc0f69d7a4d8f19e435a97bd1d570eb2b159d3e0a8b135aaa04cf02bd0a8dc216e0f6872af9c7649461 s6-portable-utils-2.2.3.3.tar.gz
+f75242ac6c06ffd5bd66b8a35bbdf39938cf3bfa6e79abd214af37e9e4acc732ca1760566862482bc964a5cca05bbce8bd24d7167b02dc66c5f397c85ee0d37f s6-portable-utils-2.3.0.3.tar.gz
"