aboutsummaryrefslogtreecommitdiffstats
path: root/main/s6-portable-utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/s6-portable-utils/APKBUILD')
-rw-r--r--main/s6-portable-utils/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/main/s6-portable-utils/APKBUILD b/main/s6-portable-utils/APKBUILD
index 577a06ad50c..9803924b03d 100644
--- a/main/s6-portable-utils/APKBUILD
+++ b/main/s6-portable-utils/APKBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Laurent Bercot <ska-devel@skarnet.org>
# Contributor: John Regan <john@jrjrtech.com>
+# Maintainer: Laurent Bercot <ska-devel@skarnet.org>
pkgname=s6-portable-utils
-pkgver=2.2.3.2
-pkgrel=0
+pkgver=2.3.0.3
+pkgrel=1
pkgdesc="skarnet.org's tiny portable generic utilities"
-url="http://skarnet.org/software/$pkgname/"
+url=https://skarnet.org/software/s6-portable-utils/
arch="all"
license="ISC"
-makedepends="skalibs-dev"
+makedepends="skalibs-dev>=2.14"
options="!check"
subpackages="$pkgname-doc"
source="https://skarnet.org/software/s6-portable-utils/s6-portable-utils-$pkgver.tar.gz"
@@ -18,12 +18,15 @@ build() {
--enable-static \
--disable-allstatic \
--prefix=/usr \
- --libdir=/usr/lib
+ --libdir=/usr/lib \
+ --enable-multicall
make
}
package() {
make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/include/s6-portable-utils/config.h
+ rmdir -p "$pkgdir"/usr/include/s6-portable-utils || :
}
doc() {
@@ -32,4 +35,6 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="3d976bb41502b86cc68d25bcde44fc218668d8d1c4c6e513ab2bc0dda459439d6d55144e503420ac38d0b052e7c678a254780f9cc6dee6ae6d6debf4d1954134 s6-portable-utils-2.2.3.2.tar.gz"
+sha512sums="
+f75242ac6c06ffd5bd66b8a35bbdf39938cf3bfa6e79abd214af37e9e4acc732ca1760566862482bc964a5cca05bbce8bd24d7167b02dc66c5f397c85ee0d37f s6-portable-utils-2.3.0.3.tar.gz
+"