summaryrefslogtreecommitdiffstats
path: root/main/sdl
diff options
context:
space:
mode:
Diffstat (limited to 'main/sdl')
-rw-r--r--main/sdl/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/main/sdl/APKBUILD b/main/sdl/APKBUILD
new file mode 100644
index 00000000000..e81c8064416
--- /dev/null
+++ b/main/sdl/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sdl
+pkgver=1.2.14
+pkgrel=0
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
+url="http://www.libsdl.org"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+depends_dev="libx11-dev libiconv-dev"
+makedepends="libxext-dev libxrender-dev libx11-dev libice-dev libsm-dev
+ libxrandr-dev mesa-dev alsa-lib-dev libiconv-dev"
+source="http://www.libsdl.org/release/SDL-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/SDL-$pkgver
+ ./configure --prefix=/usr \
+ --disable-nasm \
+ --disable-esd \
+ --enable-alsa \
+ --with-x \
+ --disable-rpath \
+ --disable-nls
+ make
+}
+
+package() {
+ cd "$srcdir"/SDL-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="e52086d1b508fa0b76c52ee30b55bec4 SDL-1.2.14.tar.gz"