aboutsummaryrefslogtreecommitdiffstats
path: root/main/sipsak
diff options
context:
space:
mode:
Diffstat (limited to 'main/sipsak')
-rw-r--r--main/sipsak/APKBUILD35
-rw-r--r--main/sipsak/fix-aaaa-record-segfault.patch4
-rw-r--r--main/sipsak/fix-inline.patch24
-rw-r--r--main/sipsak/fix-off-by-one-bugs.patch67
-rw-r--r--main/sipsak/musl-fix-strcasestr.patch6
-rw-r--r--main/sipsak/sipsak-0001-Fix-for-wrong-arity-of-callback-function-for-c-ares.patch30
6 files changed, 18 insertions, 148 deletions
diff --git a/main/sipsak/APKBUILD b/main/sipsak/APKBUILD
index 8b4dfe391d4..5047f6f1bc5 100644
--- a/main/sipsak/APKBUILD
+++ b/main/sipsak/APKBUILD
@@ -1,34 +1,25 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=sipsak
-pkgver=0.9.6
-pkgrel=11
+pkgver=0.9.7
+pkgrel=0
pkgdesc="SIP swiss army knife"
-url="http://sipsak.org/"
+url="https://github.com/nils-ohlmeier/sipsak"
arch="all"
license="GPL-2.0-or-later"
-depends=""
-makedepends="openssl-dev c-ares-dev"
-install=""
+makedepends="openssl-dev c-ares-dev autoconf automake"
subpackages="$pkgname-dbg $pkgname-doc"
-source="https://downloads.sourceforge.net/project/sipsak.berlios/${pkgname}-${pkgver}-1.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/nils-ohlmeier/sipsak/archive/$pkgver.tar.gz
musl-fix-strcasestr.patch
- fix-off-by-one-bugs.patch
- sipsak-0001-Fix-for-wrong-arity-of-callback-function-for-c-ares.patch
fix-aaaa-record-segfault.patch
- fix-inline.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
-
prepare() {
- cd "$builddir"
default_prepare
- update_config_sub
+ autoreconf --install
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,14 +30,14 @@ build() {
make
}
+check() {
+ ./sipsak --version
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="c2d62ddaf2ecc9616941cf002a0494d2f9c43747e6b527f8b1542e9b5ae143fc69b18fc140bd3f255896b0e8eb02f7d198cc1799a4041e2d0c95d90b653591fe sipsak-0.9.6-1.tar.gz
-5a9f2679ef8b5e7a7d2db79e32c2a9ca304bd507804d86628231ad273cc08810bf3470f2b3fb5e873279d619669917f81fbf9bdfe74e83e3dfa6451aa4b62e85 musl-fix-strcasestr.patch
-4f4978924482d9d8b4a1167bf968cec8c3e705ea81cd8fe4b83873f408684d43cc166d0eeeb20f7a459ff9e02ddb0cac08644d5d6f77629557d07f96f9634605 fix-off-by-one-bugs.patch
-1bfd9703029cc5e0b8bd5719d96871358c33412982a39bb1f8204ed68cd472ee3bbdee7924d4cd8f48e33299659c484709c7c347629f3771707f5e23d8eb2b2f sipsak-0001-Fix-for-wrong-arity-of-callback-function-for-c-ares.patch
-6e60e023feef1c36d4e45426568142e8aed5bcc5f91509a610dc3b0dd507677aa7a978ae2573f3f8c93f228cb415e79d92eddd6fc544897606b597d0a44aab6b fix-aaaa-record-segfault.patch
-1e21453d2a91cc4a1f0533833e260cba83107cdb340dd0c5a98446b22156650926c6d087d4074ffd5880694f3b5bac30368b40e302b8abb53da6783c3928c34a fix-inline.patch"
+sha512sums="088da5b5b81e7ff89bdc920dc8fdfc559ba36d599de9ba5ca22c35f2bea24f0c7c76e10125baa8ae517c3f03b1b936adacde4e236be8a13797651adc624f14a7 sipsak-0.9.7.tar.gz
+95fb13a5b3bc108544e6ac3a0c5e7a00890926df02b390c1fdb3e28a3cf4aa7ef3ffafd904cc4665547135fe45b412c4b676ae1c52d133d8deef62f062ac909f musl-fix-strcasestr.patch
+7bdad66145b37ca1039f01e4b523b1555bda8fc387e6b4745d53e89473c0b23d675b403b83ff9b59a75002fd26345699d71720e4c15fd419a56122dbc68c8682 fix-aaaa-record-segfault.patch"
diff --git a/main/sipsak/fix-aaaa-record-segfault.patch b/main/sipsak/fix-aaaa-record-segfault.patch
index 31f5dba373a..9eabf06f867 100644
--- a/main/sipsak/fix-aaaa-record-segfault.patch
+++ b/main/sipsak/fix-aaaa-record-segfault.patch
@@ -1,5 +1,5 @@
---- ./helper.c.orig 2015-03-17 15:34:48.109903801 -0100
-+++ ./helper.c 2015-03-17 16:08:02.954490213 -0100
+--- ./src/helper.c.orig 2015-03-17 15:34:48.109903801 -0100
++++ ./src/helper.c 2015-03-17 16:08:02.954490213 -0100
@@ -284,6 +284,8 @@
aptr = parse_rr(aptr, abuf, alen);
else
diff --git a/main/sipsak/fix-inline.patch b/main/sipsak/fix-inline.patch
deleted file mode 100644
index 1556805c82f..00000000000
--- a/main/sipsak/fix-inline.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/header_f.h.orig b/header_f.h
-index 19d22b4..64885f0 100644
---- a/header_f.h.orig
-+++ b/header_f.h
-@@ -61,5 +61,5 @@ void new_transaction(char *message);
-
- void print_message_line(char *message);
-
--inline char* get_body(char *mes);
-+extern char* get_body(char *mes);
- #endif
-diff --git a/helper.c b/helper.c
-index 547f4e7..117d6f1 100644
---- a/helper.c
-+++ b/helper.c
-@@ -299,7 +299,7 @@ static void cares_callback(void *arg, int status, int timeouts, unsigned char *a
- }
- }
-
--inline unsigned long srv_ares(char *host, int *port, char *srv) {
-+static unsigned long srv_ares(char *host, int *port, char *srv) {
- int nfds, count, srvh_len;
- char *srvh;
- fd_set read_fds, write_fds;
diff --git a/main/sipsak/fix-off-by-one-bugs.patch b/main/sipsak/fix-off-by-one-bugs.patch
deleted file mode 100644
index e61af5762c6..00000000000
--- a/main/sipsak/fix-off-by-one-bugs.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From bf9d2417a1e73697873a5f5099dac4bb3eb4b2d9 Mon Sep 17 00:00:00 2001
-From: Richard Fuchs <rfuchs@sipwise.com>
-Date: Thu, 1 Aug 2013 11:21:09 -0400
-Subject: [PATCH] fix string off-by-one bugs
-
----
- helper.c | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/helper.c b/helper.c
-index b09963c..4fbbae5 100644
---- a/helper.c
-+++ b/helper.c
-@@ -508,12 +508,12 @@ void get_fqdn(){
- memset(&hlp, 0, sizeof(hlp));
-
- if (hostname) {
-- strncpy(fqdn, hostname, FQDN_SIZE);
-- strncpy(hname, hostname, 100);
-+ strncpy(fqdn, hostname, FQDN_SIZE-1);
-+ strncpy(hname, hostname, sizeof(hname)-1);
- }
- else {
- if ((uname(&un))==0) {
-- strncpy(hname, un.nodename, 100);
-+ strncpy(hname, un.nodename, sizeof(hname)-1);
- }
- else {
- if (gethostname(&hname[0], namelen) < 0) {
-@@ -532,7 +532,7 @@ void get_fqdn(){
- snprintf(fqdn, FQDN_SIZE, "%s.%s", hname, dname);
- }
- else {
-- strncpy(fqdn, hname, FQDN_SIZE);
-+ strncpy(fqdn, hname, FQDN_SIZE-1);
- }
- #endif
- }
-@@ -541,15 +541,15 @@ void get_fqdn(){
- he=gethostbyname(hname);
- if (he) {
- if (numeric == 1) {
-- snprintf(hlp, 15, "%s", inet_ntoa(*(struct in_addr *) he->h_addr_list[0]));
-- strncpy(fqdn, hlp, FQDN_SIZE);
-+ snprintf(hlp, sizeof(hlp), "%s", inet_ntoa(*(struct in_addr *) he->h_addr_list[0]));
-+ strncpy(fqdn, hlp, FQDN_SIZE-1);
- }
- else {
- if ((strchr(he->h_name, '.'))!=NULL && (strchr(hname, '.'))==NULL) {
-- strncpy(fqdn, he->h_name, FQDN_SIZE);
-+ strncpy(fqdn, he->h_name, FQDN_SIZE-1);
- }
- else {
-- strncpy(fqdn, hname, FQDN_SIZE);
-+ strncpy(fqdn, hname, FQDN_SIZE-1);
- }
- }
- }
-@@ -561,7 +561,7 @@ void get_fqdn(){
- if ((strchr(fqdn, '.'))==NULL) {
- if (hostname) {
- fprintf(stderr, "warning: %s is not resolvable... continouing anyway\n", fqdn);
-- strncpy(fqdn, hostname, FQDN_SIZE);
-+ strncpy(fqdn, hostname, FQDN_SIZE-1);
- }
- else {
- fprintf(stderr, "error: this FQDN or IP is not valid: %s\n", fqdn);
diff --git a/main/sipsak/musl-fix-strcasestr.patch b/main/sipsak/musl-fix-strcasestr.patch
index b5f11cbbaff..987f4c4ebb9 100644
--- a/main/sipsak/musl-fix-strcasestr.patch
+++ b/main/sipsak/musl-fix-strcasestr.patch
@@ -1,10 +1,10 @@
This fixes segfault:
http://bugs.alpinelinux.org/issues/3750
-diff --git a/sipsak.h b/sipsak.h
+diff --git a/src/sipsak.h b/src/sipsak.h
index 8f5d283..f9b1b49 100644
---- a/sipsak.h
-+++ b/sipsak.h
+--- a/src/sipsak.h
++++ b/src/sipsak.h
@@ -57,7 +57,7 @@
#endif
diff --git a/main/sipsak/sipsak-0001-Fix-for-wrong-arity-of-callback-function-for-c-ares.patch b/main/sipsak/sipsak-0001-Fix-for-wrong-arity-of-callback-function-for-c-ares.patch
deleted file mode 100644
index d62ba0e276b..00000000000
--- a/main/sipsak/sipsak-0001-Fix-for-wrong-arity-of-callback-function-for-c-ares.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From eeeee47c6cb0e13619b76bc4109479e52b5dc441 Mon Sep 17 00:00:00 2001
-From: Peter Lemenkov <lemenkov@gmail.com>
-Date: Tue, 15 Nov 2011 00:33:49 +0400
-Subject: [PATCH 1/1] Fix for wrong arity of callback function for c-ares
-
-See rhbz #753372 for further details
-
-https://bugzilla.redhat.com/753372
-
-Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
----
- helper.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/helper.c b/helper.c
-index c5dee06..976b73b 100644
---- a/helper.c
-+++ b/helper.c
-@@ -262,7 +262,7 @@ static const unsigned char *skip_query(const unsigned char *aptr, const unsigned
- return aptr;
- }
-
--static void cares_callback(void *arg, int status, unsigned char *abuf, int alen) {
-+static void cares_callback(void *arg, int status, int timeouts, unsigned char *abuf, int alen) {
- int i;
- unsigned int ancount, nscount, arcount;
- const unsigned char *aptr;
---
-1.7.7
-