aboutsummaryrefslogtreecommitdiffstats
path: root/main/spice/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/spice/APKBUILD')
-rw-r--r--main/spice/APKBUILD46
1 files changed, 21 insertions, 25 deletions
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index 178c1347519..5daef9f8b4b 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -1,37 +1,38 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice
-pkgver=0.14.3
+pkgver=0.15.2
pkgrel=1
pkgdesc="Implements the SPICE protocol"
url="http://www.spice-space.org/"
arch="all"
license="LGPL-2.0-or-later"
makedepends="
- meson
- spice-protocol
- glib-dev
+ cyrus-sasl-dev
gdk-pixbuf-dev
- pixman-dev
- openssl-dev
+ glib-dev
+ gst-plugins-base-dev
+ gstreamer-dev
libjpeg-turbo-dev
- zlib-dev
+ lz4-dev
+ meson
+ openssl-dev>3
opus-dev
- gstreamer-dev
- gst-plugins-base-dev
orc-dev
- lz4-dev
- cyrus-sasl-dev
- py3-six
+ pixman-dev
py3-parsing
+ py3-six
+ spice-protocol
+ zlib-dev
"
-subpackages="$pkgname-static $pkgname-dev $pkgname-server"
+subpackages="$pkgname-dev"
source="https://www.spice-space.org/download/releases/spice-server/spice-$pkgver.tar.bz2
failing-tests.patch
- CVE-2021-20201.patch
"
# secfixes:
+# 0.15.0-r0:
+# - CVE-2020-14355
# 0.14.3-r1:
# - CVE-2021-20201
# 0.14.1-r4:
@@ -46,31 +47,26 @@ source="https://www.spice-space.org/download/releases/spice-server/spice-$pkgver
build() {
abuild-meson \
+ -Db_lto=true \
-Dgstreamer=1.0 \
-Dlz4=true \
-Dsasl=true \
-Dopus=enabled \
-Dsmartcard=disabled \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
+ provides="$pkgname-server=$pkgver-r$pkgrel"
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-server() {
- pkgdesc="Server library for SPICE"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*server.so.* "$subpkgdir"/usr/lib/
-}
-
sha512sums="
-9ecdc455ff25c71ac1fe6c576654b51efbfb860110bd6828065d23f7462d5c5cac772074d1a40f033386258d970b77275b2007bcfdffb23fdff2137154ea46e4 spice-0.14.3.tar.bz2
-15b8abdabbed501b67562497a37bfd2e622373a48b6e5c5e3b0271ecf06af0b19d0483d687714d08ea7bd2ad04d2152ec2a6ae91521d456fe8caf4a8e0b4e548 failing-tests.patch
-f7584c07c2c521c1454d1a7bc49aba4fd17553b96ce5107114e9bb02d58439cabd1471dd6e6e639a3f783255efecbd1a17cd543672a8021c9d59f68acb4fcbb7 CVE-2021-20201.patch
+c8f273b9e97ef38a03b331f7d32c5f0a09d540523fe626568c845152cbd22273a92b3a08bc13fa2e061b913ad16ceb7cbddf142655cd9cdcd8eb5f646fa6aa26 spice-0.15.2.tar.bz2
+4fe7665ba7ef63d92570a870eb74f907e9d68f465e6607de7f16233c1d4cd209f390b3d51e2f9da1dd2365027e0402c042396d049d8e78e1eebdd3f5c56686d5 failing-tests.patch
"