summaryrefslogtreecommitdiffstats
path: root/main/sshfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/sshfs/APKBUILD')
-rw-r--r--main/sshfs/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/sshfs/APKBUILD b/main/sshfs/APKBUILD
new file mode 100644
index 00000000000..f911831236c
--- /dev/null
+++ b/main/sshfs/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sshfs
+pkgver=2.2
+pkgrel=0
+pkgdesc="FUSE client based on the SSH File Transfer Protocol"
+url="http://fuse.sourceforge.net/sshfs.html"
+license="GPL"
+depends="openssh-client"
+makedepends="pkgconfig fuse-dev glib-dev"
+source="http://downloads.sourceforge.net/sourceforge/fuse/sshfs-fuse-$pkgver.tar.gz"
+
+_builddir="$srcdir"/sshfs-fuse-$pkgver
+build ()
+{
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="26e9206eb5169e87e6f95f54bc005a4f sshfs-fuse-2.2.tar.gz"