summaryrefslogtreecommitdiffstats
path: root/main/sudo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/sudo/APKBUILD')
-rw-r--r--main/sudo/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/sudo/APKBUILD b/main/sudo/APKBUILD
new file mode 100644
index 00000000000..75fd70f3c93
--- /dev/null
+++ b/main/sudo/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sudo
+pkgver=1.7.2
+pkgrel=0
+pkgdesc="Give certain users the ability to run some commands as root"
+url="http://www.sudo.ws/sudo/"
+license='custom ISC'
+depends=
+source="ftp://ftp.sudo.ws/pub/sudo/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --with-env-editor \
+ --without-pam \
+ --without-skey \
+ --without-offensive-insults \
+ || return 1
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9caba8719c3e0f163880a05f02a48249 sudo-1.7.2.tar.gz"