aboutsummaryrefslogtreecommitdiffstats
path: root/main/taglib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/taglib/APKBUILD')
-rw-r--r--main/taglib/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/main/taglib/APKBUILD b/main/taglib/APKBUILD
index 4c7231ca758..370b5bbae91 100644
--- a/main/taglib/APKBUILD
+++ b/main/taglib/APKBUILD
@@ -1,16 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=taglib
pkgver=1.11.1
-pkgrel=1
+pkgrel=2
pkgdesc="Library for reading and editing metadata of several popular audio formats"
url="http://taglib.github.io/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0"
makedepends="zlib-dev cmake"
-depends=
-source="https://taglib.github.io/releases/taglib-$pkgver.tar.gz"
subpackages="$pkgname-dev"
+source="https://taglib.github.io/releases/taglib-$pkgver.tar.gz
+ CVE-2017-12678.patch
+ CVE-2018-11439.patch
+ "
+
+# secfixes:
+# 1.11.1-r2:
+# - CVE-2017-12678
+# - CVE-2018-11439
build() {
cd "$builddir"
@@ -26,4 +34,6 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="7846775c4954ea948fe4383e514ba7c11f55d038ee06b6ea5a0a1c1069044b348026e76b27aa4ba1c71539aa8143e1401fab39184cc6e915ba0ae2c06133cb98 taglib-1.11.1.tar.gz"
+sha512sums="7846775c4954ea948fe4383e514ba7c11f55d038ee06b6ea5a0a1c1069044b348026e76b27aa4ba1c71539aa8143e1401fab39184cc6e915ba0ae2c06133cb98 taglib-1.11.1.tar.gz
+b5ac8fda91d33236951dae89b736219529dce5d521876f89b6ab8a57953c69d3a43861be035740108e4ecbb6a97146129449a9bc560118abdc3464bcd785f8ad CVE-2017-12678.patch
+9a118f9410404996bf3879325f77fcfb638f6cc71b4e258d9786bd741c2c45f26385a6049788ef6ebc56c7c987bd7ef6267a461f4478f5d52d236b035287cdf2 CVE-2018-11439.patch"