aboutsummaryrefslogtreecommitdiffstats
path: root/main/tevent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/tevent/APKBUILD')
-rw-r--r--main/tevent/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/main/tevent/APKBUILD b/main/tevent/APKBUILD
index d9acb192128..ffe5ad745bc 100644
--- a/main/tevent/APKBUILD
+++ b/main/tevent/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tevent
pkgver=0.9.36
-pkgrel=0
+pkgrel=1
pkgdesc="The tevent library"
url="http://tevent.samba.org/"
arch="all"
license="LGPL-3.0-or-later"
makedepends="libtirpc-dev python2-dev talloc-dev"
replaces="samba"
-subpackages="$pkgname-dev py-$pkgname:_py"
+subpackages="$pkgname-dev py2-$pkgname:_py2"
source="http://samba.org/ftp/tevent/tevent-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -39,10 +39,13 @@ package() {
make DESTDIR="$pkgdir" install
}
-_py() {
- pkgdesc="Python binding for the tevent library"
+_py2() {
+ pkgdesc="Python 2 binding for the tevent library"
+ provides="py-$pkgname=$pkgver-r$pkgrel" # for backward compatibility
+ replaces="py-$pkgname" # for backward compatibility
+
mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib/
}
sha512sums="bca9db9bcf142ba68b207180d19414dddb89a069a4f040383069c8af0df5bb184ca219293c4a1e7b0bc241b9a1ea3d414f8284278ad3a5f0383b9e432450167b tevent-0.9.36.tar.gz"