aboutsummaryrefslogtreecommitdiffstats
path: root/main/tevent
diff options
context:
space:
mode:
Diffstat (limited to 'main/tevent')
-rw-r--r--main/tevent/APKBUILD11
-rw-r--r--main/tevent/fix-public-header.patch13
2 files changed, 5 insertions, 19 deletions
diff --git a/main/tevent/APKBUILD b/main/tevent/APKBUILD
index b0ef80a1d60..8e131f182e3 100644
--- a/main/tevent/APKBUILD
+++ b/main/tevent/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tevent
-pkgver=0.11.0
+pkgver=0.16.1
pkgrel=0
pkgdesc="The tevent library"
url="https://tevent.samba.org/"
@@ -10,9 +10,10 @@ makedepends="libtirpc-dev python3-dev talloc-dev cmocka-dev"
replaces="samba"
subpackages="$pkgname-dev py3-$pkgname:_py3"
source="https://samba.org/ftp/tevent/tevent-$pkgver.tar.gz
- fix-public-header.patch"
+ "
build() {
+ CFLAGS="$CFLAGS -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,11 +39,9 @@ package() {
_py3() {
pkgdesc="Python 3 binding for the tevent library"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
+ amove usr/lib/python3*
}
sha512sums="
-740346b19bf290ff31b0c1b36e232021b8ad107c3ce27e0e8b1ec1a77485214b07a9b7837ba57f3650a50e4c04f530674e486b5fa4d118a1778259be63b49790 tevent-0.11.0.tar.gz
-ee4cce8591dfe31288975596d8464b7cc160580715f88e4fd19b5ae7e1a831650b072954731f015f52d76600597faee894f0174b9e92d18dca9629f9d056230c fix-public-header.patch
+cda001d91728b2f28dd081e9c5f6d8ede345dcd9ce1dca04394860cd83090c15aa8dfef1c53b73e120bd17f0d95551fa9301eb4927963314556d016fe5420a39 tevent-0.16.1.tar.gz
"
diff --git a/main/tevent/fix-public-header.patch b/main/tevent/fix-public-header.patch
deleted file mode 100644
index 2b60347aba8..00000000000
--- a/main/tevent/fix-public-header.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-tevent.h needs sys/types.h for pid_t
-
-diff -ru tevent-0.9.37.orig/tevent.h tevent-0.9.37/tevent.h
---- tevent-0.9.37.orig/tevent.h 2018-07-12 05:51:30.000000000 +0000
-+++ tevent-0.9.37/tevent.h 2018-07-19 10:13:15.360128807 +0000
-@@ -31,6 +31,7 @@
- #include <stdint.h>
- #include <talloc.h>
- #include <sys/time.h>
-+#include <sys/types.h>
- #include <stdbool.h>
-
- struct tevent_context;