aboutsummaryrefslogtreecommitdiffstats
path: root/main/tinc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/tinc/APKBUILD')
-rw-r--r--main/tinc/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/tinc/APKBUILD b/main/tinc/APKBUILD
index ffa1d7cd2bc..ef0b4996aaa 100644
--- a/main/tinc/APKBUILD
+++ b/main/tinc/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tinc
pkgver=1.0.36
-pkgrel=1
+pkgrel=6
pkgdesc="Virtual Private Network (VPN) daemon"
url="https://www.tinc-vpn.org"
arch="all"
license="GPL-2.0-or-later WITH OpenSSL-Exception"
-makedepends="zlib-dev lzo-dev openssl-dev linux-headers"
-subpackages="$pkgname-doc"
+makedepends="zlib-dev lzo-dev openssl-dev>3 linux-headers"
+subpackages="$pkgname-doc $pkgname-openrc"
source="https://www.tinc-vpn.org/packages/tinc-$pkgver.tar.gz
tincd.initd
tincd.lo.initd
@@ -24,6 +24,11 @@ check() {
make check
}
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \