aboutsummaryrefslogtreecommitdiffstats
path: root/main/tiny-ec2-bootstrap
diff options
context:
space:
mode:
Diffstat (limited to 'main/tiny-ec2-bootstrap')
-rw-r--r--main/tiny-ec2-bootstrap/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/main/tiny-ec2-bootstrap/APKBUILD b/main/tiny-ec2-bootstrap/APKBUILD
new file mode 100644
index 00000000000..418d0714625
--- /dev/null
+++ b/main/tiny-ec2-bootstrap/APKBUILD
@@ -0,0 +1,20 @@
+# Contributor: Mike Crute <mike@crute.us>
+# Maintainer: Mike Crute <mike@crute.us>
+pkgname=tiny-ec2-bootstrap
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A tiny EC2 instance bootstrapper that uses instance metadata"
+url="https://github.com/mcrute/tiny-ec2-bootstrap"
+arch="noarch"
+license="MIT"
+options="!check" # no tests provided
+depends="openrc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mcrute/$pkgname/archive/release-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-release-$pkgver"
+
+package() {
+ cd "$builddir"
+ make install PREFIX=$pkgdir
+}
+
+sha512sums="3075327ad7cf9a2eb26b3c9e98785f542f46ab8ca01125efb6a5bf34fe16a14e346bec0abfe3f09ac99a616eae361f4cbde09f41c65ba5d8fe6fea8c035e2970 tiny-ec2-bootstrap-1.0.0.tar.gz"