aboutsummaryrefslogtreecommitdiffstats
path: root/main/tinyxml2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/tinyxml2/APKBUILD')
-rw-r--r--main/tinyxml2/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/main/tinyxml2/APKBUILD b/main/tinyxml2/APKBUILD
index 1b42ce5a255..4caeb0e00d3 100644
--- a/main/tinyxml2/APKBUILD
+++ b/main/tinyxml2/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=tinyxml2
-pkgver=9.0.0
+pkgver=10.0.0
pkgrel=0
pkgdesc="Simple, small and efficient C++ XML parser"
-url="http://www.grinninglizard.com/tinyxml2"
+url="https://github.com/leethomason/tinyxml2"
arch="all"
license="Zlib"
makedepends="meson"
@@ -15,16 +15,17 @@ build() {
abuild-meson \
-Dtests=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
+
sha512sums="
-9c5ce8131984690df302ca3e32314573b137180ed522c92fd631692979c942372a28f697fdb3d5e56bcf2d3dc596262b724d088153f3e1d721c9536f2a883367 tinyxml2-9.0.0.tar.gz
+a359d33bc12fad455b53d81011dbe12727cae0aabfaa5704f1a25807ca216dd854a571291029886c0beedeca5c3b6393dd49c4718773e18a0e008abbdb3de36a tinyxml2-10.0.0.tar.gz
"