aboutsummaryrefslogtreecommitdiffstats
path: root/main/unixodbc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/unixodbc/APKBUILD')
-rw-r--r--main/unixodbc/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/main/unixodbc/APKBUILD b/main/unixodbc/APKBUILD
index e2f82ef8fd0..f8af3f90b29 100644
--- a/main/unixodbc/APKBUILD
+++ b/main/unixodbc/APKBUILD
@@ -1,21 +1,25 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=unixodbc
-pkgver=2.3.7
-pkgrel=2
+pkgver=2.3.12
+pkgrel=0
pkgdesc="ODBC is an open specification to access Data Sources"
-url="http://www.unixodbc.org/"
+url="https://www.unixodbc.org/"
arch="all"
license="LGPL-2.0-or-later"
options="!check" # No test suite.
makedepends="readline-dev"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
-source="http://www.unixodbc.org/unixODBC-${pkgver}.tar.gz"
+source="https://www.unixodbc.org/unixODBC-$pkgver.tar.gz"
builddir="$srcdir/unixODBC-$pkgver"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,8 +34,9 @@ build() {
}
package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}
-sha512sums="a87afeaaa0476f4ae6345c7021b3af52718944e599abb595c864d9126744a21341889802512a1de3ebaf86ac89e7f8b1bbd7f8f5285e8f4bccf928bd1585ff70 unixODBC-2.3.7.tar.gz"
+sha512sums="
+ca9d8db943195679a44db1fc09391dc6662ab1721112c93d448f04011e98502462ffe14b8364eb03707d851db456eced20eb61a22370392ca88d917038d45b56 unixODBC-2.3.12.tar.gz
+"