aboutsummaryrefslogtreecommitdiffstats
path: root/main/unrar
diff options
context:
space:
mode:
Diffstat (limited to 'main/unrar')
-rw-r--r--main/unrar/APKBUILD31
-rw-r--r--main/unrar/makefile.patch30
2 files changed, 0 insertions, 61 deletions
diff --git a/main/unrar/APKBUILD b/main/unrar/APKBUILD
deleted file mode 100644
index dc84b1b3448..00000000000
--- a/main/unrar/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=unrar
-pkgver=6.0.7
-pkgrel=0
-pkgdesc="RAR uncompression program"
-url="https://www.rarlab.com/rar_add.htm"
-arch="all"
-options="!check" # no test suite
-license="custom"
-subpackages="$pkgname-doc"
-source="https://www.rarlab.com/rar/unrarsrc-$pkgver.tar.gz
- makefile.patch"
-builddir="$srcdir/$pkgname"
-
-build() {
- make CXX="${CXX:-g++}" STRIP=: -f makefile
-}
-
-package() {
- make DESTDIR="$pkgdir"/usr install
-
- install -Dm644 license.txt \
- "$pkgdir"/usr/share/licenses/$pkgname/license.txt
-}
-
-sha512sums="
-2c50d1f58f5189e59dad36eb25aa50a34572f583242e624846c9791c5609e83d4ee76314d785771fe514ec3378749dcb86e4c97a8d2a3ab7b469df49a5c5f412 unrarsrc-6.0.7.tar.gz
-2caa145c2fb1257c3cea1f552cba7bf8a3f8772c65c9751aad3fb5bec4957c7fefdb7bbb016c94b73d4778cef76460ddc2abafa8a12d09ebd24bcb6f1dcb263c makefile.patch
-"
diff --git a/main/unrar/makefile.patch b/main/unrar/makefile.patch
deleted file mode 100644
index f54b4533e4d..00000000000
--- a/main/unrar/makefile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -upr unrar.orig/makefile unrar/makefile
---- unrar.orig/makefile 2018-03-11 17:33:12.697132381 +0100
-+++ unrar/makefile 2018-03-11 17:33:48.763911497 +0100
-@@ -2,13 +2,14 @@
- # Makefile for UNIX - unrar
-
- # Linux using GCC
--CXX=c++
--CXXFLAGS=-O2 -Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
-+CXX?=c++
-+CXXFLAGS?=-O2
-+CXXFLAGS+=-Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
- LIBFLAGS=-fPIC
- DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DRAR_SMP
- STRIP=strip
- AR=ar
--LDFLAGS=-pthread
-+LDFLAGS+=-pthread
- DESTDIR=/usr
-
- # Linux using LCC
-@@ -140,7 +141,7 @@ uninstall: uninstall-unrar
- clean:
- @rm -f *.o *.bak *~
-
--unrar: clean $(OBJECTS) $(UNRAR_OBJ)
-+unrar: $(OBJECTS) $(UNRAR_OBJ)
- @rm -f unrar
- $(LINK) -o unrar $(LDFLAGS) $(OBJECTS) $(UNRAR_OBJ) $(LIBS)
- $(STRIP) unrar