aboutsummaryrefslogtreecommitdiffstats
path: root/main/util-linux/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/util-linux/APKBUILD')
-rw-r--r--main/util-linux/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index 6ae351daa6d..49e930c2298 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -9,14 +9,14 @@ case $pkgver in
*.*) _v=$pkgver;;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Random collection of Linux utilities"
url="https://git.kernel.org/cgit/utils/util-linux/util-linux.git"
arch="all"
license="GPL-2.0 GPL-2.0-or-later LGPL-2.0-or-later BSD Public-Domain"
depends="blkid setpriv findmnt mcookie hexdump lsblk sfdisk cfdisk"
makedepends_build="autoconf automake libtool"
-makedepends_host="zlib-dev ncurses-dev linux-headers libcap-ng-dev"
+makedepends_host="zlib-dev ncurses-dev linux-headers libcap-ng-dev linux-pam-dev"
options="suid"
source="https://www.kernel.org/pub/linux/utils/util-linux/v$_v/util-linux-$pkgver.tar.xz
ttydefaults.h
@@ -36,6 +36,7 @@ subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion:bashcomp:noarch
mcookie:_mv_bin
setpriv:_mv_bin
sfdisk:_mv_bin
+ runuser:_mv_bin
"
if [ -z "$BOOTSTRAP" ]; then
makedepends_host="$makedepends_host python3-dev"
@@ -60,6 +61,8 @@ build() {
--host=$CHOST \
--with-sysroot=$CBUILDROOT \
--prefix=/usr \
+ --enable-runuser \
+ --disable-chfn-chsh \
--enable-raw \
--disable-uuidd \
--disable-nls \
@@ -88,6 +91,7 @@ _mv_bin() {
sfdisk) pkgdesc="Partition table manipulator from util-linux";;
cfdisk) pkgdesc="Curses based partition table manipulator from util-linux";;
setpriv) pkgdesc="Run a program with different Linux privilege settings";;
+ runuser) pkgdesc="Run a program with substitute user and group ID";;
*);;
esac
local _path; for _path in usr/bin usr/sbin bin sbin; do