aboutsummaryrefslogtreecommitdiffstats
path: root/main/uwsgi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/uwsgi/APKBUILD')
-rw-r--r--main/uwsgi/APKBUILD98
1 files changed, 46 insertions, 52 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index b51d893fdd1..fedace57f3b 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
-# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Contributor: Kaarle Ritvanen <kunkku@alpinelinux.org>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uwsgi
-pkgver=2.0.18
-pkgrel=1
+pkgver=2.0.25.1
+pkgrel=0
pkgdesc="uWSGI application container server"
-url="http://projects.unbit.it/uwsgi/"
+url="https://projects.unbit.it/uwsgi/"
arch="all"
-license="custom" # GPL-2.0-only + linking exception
+license="GPL-2.0-only WITH GCC-exception-2.0"
depends="mailcap"
-install="uwsgi.pre-install"
+install="$pkgname.pre-install $pkgname.post-upgrade"
pkgusers="uwsgi"
pkggroups="uwsgi"
makedepends="
@@ -19,35 +19,33 @@ makedepends="
geoip-dev
jansson-dev
libcap-dev
+ libucontext-dev
linux-headers
linux-pam-dev
+ libpq-dev
libxml2-dev
libxslt-dev
lua5.3-dev
- paxmark
- pcre-dev
- postgresql-dev
- python
- python2-dev
+ openssl-dev
+ pcre2-dev
python3-dev
zeromq-dev
zlib-dev
"
-source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
+subpackages="$pkgname-openrc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/unbit/uwsgi/archive/refs/tags/$pkgver.tar.gz
uwsgi.initd
uwsgi.ini
readme.emperor
alpine.buildconf
- musl-fix-python.patch
+ musl-ucontext.patch
"
options="!check"
-builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 2.0.16-r0:
# - CVE-2018-6758
-# Plugins for Python 2 or without compile dependency on Python.
# You may specify a custom name for so lib and subpackage after a colon.
_plugins="
alarm_curl
@@ -67,7 +65,7 @@ _plugins="
fastrouter
forkptyrouter
geoip
- gevent
+ gevent:gevent3
graylog2
http
legion_cache_fetch
@@ -83,7 +81,7 @@ _plugins="
pam
ping
pty
- python
+ python:python3
rawrouter
redislog
router_basicauth
@@ -122,56 +120,37 @@ _plugins="
zabbix
zergpool
"
-# Plugins for Python 3.
-# You may specify a custom name for so lib and subpackage after a colon.
-_plugins3="gevent:gevent3 python:python3"
-subpackages=""
-for _p in $_plugins $_plugins3; do
+for _p in $_plugins; do
subpackages="$subpackages uwsgi-${_p#*:}:_plugin"
done
-_desc_gevent="uWSGI plugin for gevent (Python 2)"
-_desc_gevent3="uWSGI plugin for gevent (Python 3)"
-_desc_python="uWSGI plugin for Python 2"
-_desc_python3="uWSGI plugin for Python 3"
-
-
prepare() {
default_prepare
cp "$srcdir"/alpine.buildconf buildconf/alpine.ini
}
build() {
- cd "$builddir"
-
msg "Building core"
# ccache seems to trigger some weird bug on musl
- CC="gcc" python2 uwsgiconfig.py --build alpine
+ CC="gcc" python3 uwsgiconfig.py --build alpine
export UWSGICONFIG_LUAPC="lua5.3"
- local item
- for item in $_plugins; do
- _build python "$item"
- done
- for item in $_plugins3; do
- _build python3 "$item"
+ local item; for item in $_plugins; do
+ _build_plugin "${item%:*}" "${item#*:}"
done
}
-_build() {
- local python="$1"
- local plugin="${2%:*}"
- local myname="${2#*:}"
+_build_plugin() {
+ local plugin="$1"
+ local myname="$2"
msg "Building $plugin plugin ($myname)"
- $python uwsgiconfig.py --plugin plugins/$plugin alpine $myname
+ python3 uwsgiconfig.py --plugin plugins/$plugin alpine $myname
}
package() {
- cd "$builddir"
-
install -m 755 -D uwsgi "$pkgdir"/usr/sbin/uwsgi
install -m 644 -D "$srcdir"/readme.emperor "$pkgdir"/etc/uwsgi/conf.d/readme.emperor
install -m 644 -D "$srcdir"/uwsgi.ini "$pkgdir"/etc/uwsgi/uwsgi.ini
@@ -179,15 +158,11 @@ package() {
install -m 775 -d -o root -g uwsgi "$pkgdir"/var/log/uwsgi
install -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-
- # Disable emutramp/mprotect, this is needed for luajit and cffi.
- paxmark -em "$pkgdir"/usr/sbin/uwsgi
}
_plugin() {
local name="${subpkgname#$pkgname-}"
- local desc="$(eval "echo \$_desc_$name")"
- pkgdesc="${desc:-"uWSGI plugin $name"}"
+ pkgdesc="uWSGI plugin $name"
depends="uwsgi"
cd "$builddir"
@@ -206,11 +181,30 @@ _plugin() {
install -m 755 -D ${name}_plugin.so \
"$subpkgdir"/usr/lib/uwsgi/${name}_plugin.so
+
+ case "$name" in
+ # Mitigate breakages caused by injudicious rename in v3.11.
+ python3)
+ pkgdesc="uWSGI plugin for Python 3"
+ provides="uwsgi-python=$pkgver-r$pkgrel"
+ replaces="uwsgi-python"
+ ln -s python3_plugin.so "$subpkgdir"/usr/lib/uwsgi/python_plugin.so
+ ;;
+ # Mitigate breakages caused by injudicious rename in v3.11.
+ gevent3)
+ pkgdesc="uWSGI plugin for gevent (Python 3)"
+ provides="uwsgi-gevent=$pkgver-r$pkgrel"
+ replaces="uwsgi-gevent"
+ ln -s gevent3_plugin.so "$subpkgdir"/usr/lib/uwsgi/gevent_plugin.so
+ ;;
+ esac
}
-sha512sums="6561703279bcc4a81311d033810ac066d0f113bab13b0942f3eef86cac29c584a6641b52476840d6895151aee5ed064ae2d03b18932cf7f47e62f4eeed76da61 uwsgi-2.0.18.tar.gz
-63137d45437e00deb970d66e2abddf7f235636b748f6cf545f54ff5557066c2a71db5c4a3bab2edceb4e65d3d7fac887f1f4c0e77658127e02b64d3026780b4c uwsgi.initd
+sha512sums="
+3b2a78917b129f5a2f38f3538e30b132e4cd6e270df55365ccc0dc6b94641a262af1484c62b252d0a24121eb68417cb061210e89e2b7885992ab4ffa07092119 uwsgi-2.0.25.1.tar.gz
+1fef8a30e8e20b0322cf464a2adf744a4b46a35f4c9e104acacab4c99b913c5a0b537783bdfedf8900a4e7397e08079b675be2414beb571fd0b330985ac676cc uwsgi.initd
370202e143d0e041a2e36905346080d3ca592c9a74705a8c4e142a1307d22b921c10e673d683ca284ea27d184474ed86edd7723a6e590d35a562ad7cf6afa529 uwsgi.ini
2798c9d2e49e29292ffe6a5a29b866301c78d5f322fc5d07dfa9569efdaa5220237a5f6744652fbdd957be29311ddaff190541333f042cbf0e907dfa98ce3e2a readme.emperor
f3cff00926929a5bb40afafb65fd5228582af35fbf524562282020c4c4ae9c659231b2381f4b3cceb18e8f3f6c888c21bdd8ed4ddcd81e92fbc6a0891800ce38 alpine.buildconf
-de68b16b44e554a79c073c9befa10566796316dbf4c375b4d6b633d80b0282694cca233f0a70f3d6570584324f14276826bbeb8f38b550c00087a05f9ba9227f musl-fix-python.patch"
+d4b93e51619af5f8839cdc7279c69462947910df03104cfe6180d606403940fc60ad5dac66425ce8acbab67cc0c4f3e13126da0a329720cb03c67d447cd94ad9 musl-ucontext.patch
+"