aboutsummaryrefslogtreecommitdiffstats
path: root/main/uwsgi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/uwsgi/APKBUILD')
-rw-r--r--main/uwsgi/APKBUILD19
1 files changed, 17 insertions, 2 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index 2e53487b775..20a215127a3 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -64,7 +64,7 @@ _plugins="
fastrouter
forkptyrouter
geoip
- gevent
+ gevent:gevent3
graylog2
http
legion_cache_fetch
@@ -80,7 +80,7 @@ _plugins="
pam
ping
pty
- python
+ python:python3
rawrouter
redislog
router_basicauth
@@ -194,6 +194,21 @@ _plugin() {
install -m 755 -D ${name}_plugin.so \
"$subpkgdir"/usr/lib/uwsgi/${name}_plugin.so
+
+ case "$name" in
+ # Mitigate breakages caused by injudicious rename in v3.11.
+ python3)
+ provides="uwsgi-python=$pkgver-r$pkgrel"
+ replaces="uwsgi-python"
+ ln -s python3_plugin.so "$subpkgdir"/usr/lib/uwsgi/python_plugin.so
+ ;;
+ # Mitigate breakages caused by injudicious rename in v3.11.
+ gevent3)
+ provides="uwsgi-gevent=$pkgver-r$pkgrel"
+ replaces="uwsgi-gevent"
+ ln -s gevent3_plugin.so "$subpkgdir"/usr/lib/uwsgi/gevent_plugin.so
+ ;;
+ esac
}
sha512sums="6561703279bcc4a81311d033810ac066d0f113bab13b0942f3eef86cac29c584a6641b52476840d6895151aee5ed064ae2d03b18932cf7f47e62f4eeed76da61 uwsgi-2.0.18.tar.gz