aboutsummaryrefslogtreecommitdiffstats
path: root/main/valgrind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/valgrind/APKBUILD')
-rw-r--r--main/valgrind/APKBUILD53
1 files changed, 24 insertions, 29 deletions
diff --git a/main/valgrind/APKBUILD b/main/valgrind/APKBUILD
index 9ebd0b295e5..4ba0bcd6271 100644
--- a/main/valgrind/APKBUILD
+++ b/main/valgrind/APKBUILD
@@ -1,27 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=valgrind
-pkgver=3.19.0
-pkgrel=0
-pkgdesc="A tool to help find memory-management problems in programs"
+pkgver=3.22.0
+pkgrel=1
+pkgdesc="Tool to help find memory-management problems in programs"
url="https://valgrind.org/"
-# armv6 not supported upstream, broken with mips64 softfloat
-arch="all !armhf !mips64 !riscv64"
+# armv6/riscv64 not supported upstream
+arch="all !armhf !riscv64"
license="GPL-2.0-or-later"
# it seems like busybox sed works but the configure script requires GNU sed
-makedepends="sed perl bash autoconf automake libtool linux-headers"
+makedepends="sed perl linux-headers"
# from README_PACKAGERS:
# Don't strip the debug info off lib/valgrind/$platform/vgpreload*.so
# in the installation tree. Either Valgrind won't work at all, or it
# will still work if you do, but will generate less helpful error
# messages.
options="!strip"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-scripts $pkgname-dev $pkgname-doc"
source="https://sourceware.org/pub/valgrind/valgrind-$pkgver.tar.bz2
- musl.supp
- uclibc.patch
- valgrind-3.13.0-malloc.patch
+ 0001-Bug-478624-Valgrind-incompatibility-with-binutils-2..patch
"
-builddir="$srcdir"/$pkgname-$pkgver
# Valgrind 3.19.0 added support for compiling the tests on musl.
# However, it seems they haven't tested this on many architectures.
@@ -32,19 +29,8 @@ case "$CARCH" in
aarch64|s390x|armv7|x86) options="$options !check"
esac
-prepare() {
- default_prepare
- cd "$builddir"
- cp "$srcdir"/musl.supp .
- aclocal && autoconf && automake --add-missing
- echo '#include <linux/a.out.h>' > include/a.out.h
-}
-
build() {
- cd "$builddir"
- # fails to build with ccache
- export CC="gcc"
- export CFLAGS="$CFLAGS -fno-stack-protector -no-pie"
+ export CFLAGS="${CFLAGS/-fno-plt} -fno-stack-protector -no-pie -U_FORTIFY_SOURCE"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -58,12 +44,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# we have options=!strip above so we strip the /usr/bin/* manually
@@ -74,9 +58,20 @@ package() {
fi
}
+scripts() {
+ pkgdesc="$pkgdesc (perl+python cachegrind/callgrind script tools)"
+ depends="$pkgname=$pkgver-r$pkgrel python3 perl"
+
+ amove \
+ usr/bin/ms_print \
+ usr/bin/cg_merge \
+ usr/bin/cg_annotate \
+ usr/bin/cg_diff \
+ usr/bin/callgrind_control \
+ usr/bin/callgrind_annotate
+}
+
sha512sums="
-f720a89dc4c4989cc5714bff9efe97529f71990bcfad7a92b889ce099c4326d6da07fa4d5fbab2e9125e20f352354f6178471e49e419b613a3c82c2a1c667ab2 valgrind-3.19.0.tar.bz2
-49df485f158a7f4d354b2ed0d46dcc691f0490f50913c83dabfdd513b47ef1045f140fd59f54b560df05e4f3a4aba63de7124553b396189fa3ac89c908831e45 musl.supp
-d59a10db9037e120df2ee94a103402ca95a79abee9d8be63e4e1bca29c82dca775cc402a79b854ec11a2160a4d2da202c237369418e221d1925267ea2613fd5d uclibc.patch
-57086a768f3876b26b0e507bc159a73f0955f03d5af8cc30e21103e348ca67f2e58b5555a5a97f299751c6602692ad43d8346bb68a80917d740fb4d65bba9665 valgrind-3.13.0-malloc.patch
+2904c13f68245bbafcea70998c6bd20725271300a7e94b6751ca00916943595fc3fac8557da7ea8db31b54a43f092823a0a947bc142829da811d074e1fe49777 valgrind-3.22.0.tar.bz2
+250cac58cd1710d4d9a6a24b9acc596fa01e4d2255b98b46b8ed5c7af9e658489a69b51ca7e7d17ebf5b2a9023f561391e149311c20e99607d6b7e471110cbe5 0001-Bug-478624-Valgrind-incompatibility-with-binutils-2..patch
"