aboutsummaryrefslogtreecommitdiffstats
path: root/main/wayland-protocols/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wayland-protocols/APKBUILD')
-rw-r--r--main/wayland-protocols/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/main/wayland-protocols/APKBUILD b/main/wayland-protocols/APKBUILD
index 02a573881a4..23ecbce37c3 100644
--- a/main/wayland-protocols/APKBUILD
+++ b/main/wayland-protocols/APKBUILD
@@ -1,24 +1,31 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Peter Shkenev <santurysim@gmail.com>
pkgname=wayland-protocols
-pkgver=1.24
+pkgver=1.34
pkgrel=0
pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
url="https://wayland.freedesktop.org"
arch="noarch"
license="MIT"
-provides="$pkgname-dev"
+provides="$pkgname-dev=$pkgver-r$pkgrel"
makedepends="meson wayland-dev"
-source="https://wayland.freedesktop.org/releases/wayland-protocols-$pkgver.tar.xz"
-options="!check" # tests are busted
+source="https://gitlab.freedesktop.org/wayland/wayland-protocols/-/releases/$pkgver/downloads/wayland-protocols-$pkgver.tar.xz"
+
+case "$CARCH" in
+ppc64le)
+ # xdg_toplevel_interface: symbol not found in a test
+ options="$options !check"
+ ;;
+esac
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -26,5 +33,5 @@ package() {
}
sha512sums="
-4b1122517db56f48a5fafd4bd0cb7f94faef6fdd2d80e6cec17e5a6bafbaf2f5a71b958ed12e6d13965494885c209b2fb6dd8331487b39c6f251e71f1e770a15 wayland-protocols-1.24.tar.xz
+d180eaaf87281dc7adade19070ee8308a5cb3dc2f60cff077960436ad647d3d207eb63fa0b079b7b315109654ad6e6b5e2588bfe859900e67edf8c67b1c3ad20 wayland-protocols-1.34.tar.xz
"