aboutsummaryrefslogtreecommitdiffstats
path: root/main/wayland-protocols/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wayland-protocols/APKBUILD')
-rw-r--r--main/wayland-protocols/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/main/wayland-protocols/APKBUILD b/main/wayland-protocols/APKBUILD
index 105ab56e3c7..fe6141153b8 100644
--- a/main/wayland-protocols/APKBUILD
+++ b/main/wayland-protocols/APKBUILD
@@ -1,24 +1,31 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Peter Shkenev <santurysim@gmail.com>
pkgname=wayland-protocols
-pkgver=1.21
+pkgver=1.35
pkgrel=0
pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
url="https://wayland.freedesktop.org"
arch="noarch"
license="MIT"
-provides="$pkgname-dev"
+provides="$pkgname-dev=$pkgver-r$pkgrel"
makedepends="meson wayland-dev"
-source="https://wayland.freedesktop.org/releases/wayland-protocols-$pkgver.tar.xz"
-options="!check" # tests are busted
+source="https://gitlab.freedesktop.org/wayland/wayland-protocols/-/releases/$pkgver/downloads/wayland-protocols-$pkgver.tar.xz"
+
+case "$CARCH" in
+ppc64le)
+ # xdg_toplevel_interface: symbol not found in a test
+ options="$options !check"
+ ;;
+esac
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -26,5 +33,5 @@ package() {
}
sha512sums="
-40133ba36d4201de9626e9869ebdf2d4f7ad06904d6a747d5af87958a08368abdc65be3acc21b8959d0c5ec37d47051ba5b81d3844079fe237dac81a7291bbb8 wayland-protocols-1.21.tar.xz
+b4b915e145955f9c844d7ce4564ad13a854a4e7d4355913ef4cae7f09ab3e52ee69dceb6c76c9b7f82f1ab5c01071f0e5b00ce75cc7ab58274201eb4a4639710 wayland-protocols-1.35.tar.xz
"