aboutsummaryrefslogtreecommitdiffstats
path: root/main/wayland/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wayland/APKBUILD')
-rw-r--r--main/wayland/APKBUILD54
1 files changed, 35 insertions, 19 deletions
diff --git a/main/wayland/APKBUILD b/main/wayland/APKBUILD
index aee4787d49c..9974f54e752 100644
--- a/main/wayland/APKBUILD
+++ b/main/wayland/APKBUILD
@@ -1,42 +1,60 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
-# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Peter Shkenev <santurysim@gmail.com>
pkgname=wayland
-pkgver=1.20.0
-pkgrel=0
+pkgver=1.22.0
+pkgrel=4
pkgdesc="A computer display server protocol"
url="https://wayland.freedesktop.org"
arch="all"
license="MIT"
-depends="$pkgname-libs-client $pkgname-libs-cursor $pkgname-libs-egl $pkgname-libs-server"
-depends_dev="libffi-dev expat-dev"
-makedepends="$depends_dev libxml2-dev meson"
-subpackages="$pkgname-dbg $pkgname-dev $pkgname-libs-client:_libs $pkgname-libs-egl:_libs
- $pkgname-libs-cursor:_libs $pkgname-libs-server:_libs"
-source="https://wayland.freedesktop.org/releases/wayland-$pkgver.tar.xz
- tests-ignore-debugger.patch
+depends_dev="
+ expat-dev
+ libffi-dev
"
+makedepends="
+ $depends_dev
+ libxml2-dev
+ meson
+ "
+subpackages="
+ $pkgname-dbg
+ $pkgname-dev
+ $pkgname-libs-client:_libs
+ $pkgname-libs-egl:_libs
+ $pkgname-libs-cursor:_libs
+ $pkgname-libs-server:_libs
+ "
+source="https://gitlab.freedesktop.org/wayland/wayland/-/releases/$pkgver/downloads/wayland-$pkgver.tar.xz"
build() {
abuild-meson \
+ -Db_lto=true \
-Ddocumentation=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ XDG_RUNTIME_DIR="$(mktemp -d)" \
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
+ depends="
+ $pkgname-libs-client=$pkgver-r$pkgrel
+ $pkgname-libs-cursor=$pkgver-r$pkgrel
+ $pkgname-libs-egl=$pkgver-r$pkgrel
+ $pkgname-libs-server=$pkgver-r$pkgrel
+ "
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
dev() {
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$pkgdir"/usr/share \
- "$subpkgdir"/usr
+ amove usr/share
+ amove usr/bin
default_dev
}
@@ -47,11 +65,9 @@ _libs() {
case "$name" in
egl) replaces="mesa-libwayland-egl";;
esac
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*-$name.so.* "$subpkgdir"/usr/lib
+ amove usr/lib/*-$name.so.*
}
sha512sums="
-e8a1f410994b947f850799bdd0d95a2429d8467f853e62a0ab3915a4e9fe130f8aa977e03715114ab740c6ec546edea63d275ce7f927d4f3029ea126e6a7d215 wayland-1.20.0.tar.xz
-0f65a55265e9134ab08cabf67f9d1919c85c4cb6b69129e78bc6c50057cafcaf143007716a0fa73b2eb43d6b605944c320a12a36dbb5f15fcd2f5e770248c480 tests-ignore-debugger.patch
+fb1974efc8433e97254eb83fe28974198f2b4d8246418eb3d34ce657055461e0c97bc06dd52e5066ae91bbe05bac611dc49a0937ba226ac6388d5a47241efb12 wayland-1.22.0.tar.xz
"