aboutsummaryrefslogtreecommitdiffstats
path: root/main/wipe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wipe/APKBUILD')
-rw-r--r--main/wipe/APKBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/main/wipe/APKBUILD b/main/wipe/APKBUILD
index c3c633ae207..5c6fc73736e 100644
--- a/main/wipe/APKBUILD
+++ b/main/wipe/APKBUILD
@@ -2,41 +2,35 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wipe
pkgver=2.3.1
-pkgrel=0
+pkgrel=4
pkgdesc="Secure file wiping utility"
-url="http://wipe.sourceforge.net/"
+url="https://wipe.sourceforge.net/"
arch="all"
-license="GPL-2.0"
-depends=""
-depends_dev=""
-makedepends="$depends_dev linux-headers"
-install=""
+license="GPL-2.0-only"
+makedepends="linux-headers"
subpackages="$pkgname-doc"
-source="https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2
+source="https://downloads.sourceforge.net/wipe/wipe-$pkgver.tar.bz2
stdint.patch
"
+options="!check"
-builddir="$srcdir"/wipe-$pkgver
prepare() {
update_config_sub
default_prepare
}
build() {
- cd "$builddir"
CPPFLAGS= ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ --mandir=/usr/share/man
+ make
}
package() {
- cd "$builddir"
install -d "$pkgdir"/usr/bin
- make prefix="$pkgdir"/usr mandir="$pkgdir"/usr/share/man install || return 1
+ make prefix="$pkgdir"/usr mandir="$pkgdir"/usr/share/man install
}
sha512sums="63870e68fa5dbf90abb686052f8dcc216ccb93b0c4f5cc10d60ccf43f3606ba91b46dc1e3d8b34d201f7ea657f70b45a61d5d04facf5b2a3e47d2286c46e7110 wipe-2.3.1.tar.bz2