aboutsummaryrefslogtreecommitdiffstats
path: root/main/wpa_supplicant/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wpa_supplicant/APKBUILD')
-rw-r--r--main/wpa_supplicant/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/main/wpa_supplicant/APKBUILD b/main/wpa_supplicant/APKBUILD
index 4cc9b4c2a3..53b63a4981 100644
--- a/main/wpa_supplicant/APKBUILD
+++ b/main/wpa_supplicant/APKBUILD
@@ -2,10 +2,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wpa_supplicant
pkgver=2.9
-pkgrel=12
+pkgrel=13
pkgdesc="utility providing key negotiation for WPA wireless networks"
url="https://w1.fi/wpa_supplicant/"
arch="all"
+options="!check" # has no tests
license="BSD-3-Clause"
subpackages="$pkgname-doc $pkgname-openrc"
makedepends="linux-headers openssl-dev dbus-dev libnl3-dev pcsc-lite-dev"
@@ -20,11 +21,14 @@ source="https://w1.fi/releases/wpa_supplicant-$pkgver.tar.gz
CVE-2019-16275.patch
CVE-2021-0326.patch
CVE-2021-27803.patch
+ CVE-2021-30004.patch::https://w1.fi/cgit/hostap/patch/?id=a0541334a6394f8237a4393b7372693cd7e96f15
config
wpa_cli.sh"
# secfixes:
+# 2.9-r13:
+# - CVE-2021-30004
# 2.9-r12:
# - CVE-2021-27803
# 2.9-r10:
@@ -62,11 +66,7 @@ prepare() {
build() {
cd "$builddir"/wpa_supplicant
make LIBDIR=/lib BINDIR=/sbin
-}
-
-check() {
- cd "$builddir"/wpa_supplicant
- make eapol_test
+ make LIBDIR=/lib BINDIR=/sbin eapol_test
}
package() {
@@ -111,5 +111,6 @@ f4b9c86530a2b10cd50e6014c9bee1d143714ab9f86bf29119dcd2c86dec5239c356518a36147d64
63710cfb0992f2c346a9807d8c97cbeaed032fa376a0e93a2e56f7742ce515e9c4dfadbdb1af03ba272281f639aab832f0178f67634c222a5d99e1d462aa9e38 CVE-2019-16275.patch
e212dd6a2c56c086c14a2c96f479f7a8e6521b6a24c648eb03363db078398e64a38e343ff6faa327d5a0244a7969ecd34c5844d676c697eeb8eb842101fa9cf9 CVE-2021-0326.patch
af8b4a526a6833de4921fcbbd1b03da7e027276c909d512bd59a95e9767ffe8580135f9aee8947c4317681c4fe130f7ec50cba947f8375313f832a66c66b2cd5 CVE-2021-27803.patch
+88608529763a6fd9e8cb1e9c9a35630dc2e311a260e023e2a69002d0db700d5f58fc7723a00433b4ea895b92c371cf1db221f38742490b4ed9b4b049892b65e1 CVE-2021-30004.patch
6dc37bd22a1c3ea15c855f8b9fa522c31dcb4459bfa5e2f471306db0d3d835f3ddb39cc0a128b42b785079b8d5faf83c3494d6c6c5bb67ad8543ce57e99ee6d0 config
212c4265afce2e72b95a32cd785612d6c3e821b47101ead154136d184ac4add01434ada6c87edbb9a98496552e76e1a4d79c6b5840e3a5cfe5e6d602fceae576 wpa_cli.sh"