aboutsummaryrefslogtreecommitdiffstats
path: root/main/wv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wv/APKBUILD')
-rw-r--r--main/wv/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/main/wv/APKBUILD b/main/wv/APKBUILD
index c677edfeb96..8095cda2058 100644
--- a/main/wv/APKBUILD
+++ b/main/wv/APKBUILD
@@ -1,24 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wv
pkgver=1.2.9
-pkgrel=2
-pkgdesc="MSWord library can load and parse Word 2000, 97, 95 and 6 file formats"
+pkgrel=3
+pkgdesc="A library that can load and parse Word 2000, 97, 95 and 6 file formats"
url="http://sourceforge.net/projects/wvware"
arch="all"
-license="GPL"
+license="GPL2+"
subpackages="$pkgname-dev $pkgname-doc"
-depends=
+depends=""
makedepends="libgsf-dev libpng-dev bzip2-dev coreutils"
source="http://www.abisource.com/downloads/wv/$pkgver/wv-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
update_config_sub || return 1
# patch -p1 -i "$srcdir"/fix-soname.patch
}
-build () {
- cd "$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,8 +30,9 @@ build () {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la
}
+
md5sums="dbccf2e9f747e50c913b7e3d126b73f7 wv-1.2.9.tar.gz"