summaryrefslogtreecommitdiffstats
path: root/main/xcb-proto
diff options
context:
space:
mode:
Diffstat (limited to 'main/xcb-proto')
-rw-r--r--main/xcb-proto/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/xcb-proto/APKBUILD b/main/xcb-proto/APKBUILD
new file mode 100644
index 00000000000..b5b6d966f2d
--- /dev/null
+++ b/main/xcb-proto/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xcb-proto
+pkgver=1.6
+pkgrel=0
+pkgdesc="XML-XCB protocol descriptions"
+url="http://xcb.freedesktop.org/"
+license="custom"
+depends=
+makedepends="python"
+source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+}
+md5sums="04313e1d914b44d0e457f6c494fc178b xcb-proto-1.6.tar.bz2"