summaryrefslogtreecommitdiffstats
path: root/main/xfce4-xkb-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xfce4-xkb-plugin/APKBUILD')
-rw-r--r--main/xfce4-xkb-plugin/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/xfce4-xkb-plugin/APKBUILD b/main/xfce4-xkb-plugin/APKBUILD
new file mode 100644
index 00000000000..c7136cee389
--- /dev/null
+++ b/main/xfce4-xkb-plugin/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-xkb-plugin
+pkgver=0.5.3.3
+pkgrel=1
+pkgdesc="plugin to switch keyboard layouts for the Xfce4 panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+license="custom"
+subpackages="$pkgname-doc"
+depends=
+makedepends="xfce4-panel-dev libxklavier-dev librsvg-dev intltool libwnck-dev
+ libxi-dev libxkbfile-dev libsm-dev libgsf-dev e2fsprogs-dev bzip2-dev"
+source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ xfce4-xkb-plugin-0.5.3.3-libxklavier.patch"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 -i ../xfce4-xkb-plugin-0.5.3.3-libxklavier.patch || return 1
+}
+
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="b233cc9de1cbace075eaf6e2c9a8e685 xfce4-xkb-plugin-0.5.3.3.tar.gz
+f805bf4d31d1a55176e479a3c253df95 xfce4-xkb-plugin-0.5.3.3-libxklavier.patch"