aboutsummaryrefslogtreecommitdiffstats
path: root/main/xkeyboard-config/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xkeyboard-config/APKBUILD')
-rw-r--r--main/xkeyboard-config/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/main/xkeyboard-config/APKBUILD b/main/xkeyboard-config/APKBUILD
index e94d02c8aeb..740de0bf2c5 100644
--- a/main/xkeyboard-config/APKBUILD
+++ b/main/xkeyboard-config/APKBUILD
@@ -1,28 +1,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xkeyboard-config
-pkgver=2.34
+pkgver=2.41
pkgrel=0
pkgdesc="X keyboard configuration files"
-url="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+url="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
arch="noarch"
license="MIT"
-subpackages="$pkgname-doc"
-makedepends="meson perl libxslt"
-source="https://www.x.org/archive/individual/data/xkeyboard-config/xkeyboard-config-$pkgver.tar.bz2
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends_dev="$pkgname"
+makedepends="gettext meson perl libxslt"
+checkdepends="gawk"
+source="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/-/archive/xkeyboard-config-$pkgver/xkeyboard-config-xkeyboard-config-$pkgver.tar.gz
"
+builddir="$srcdir"/xkeyboard-config-xkeyboard-config-$pkgver
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
+
sha512sums="
-cf3bdb658349b2db9db44ea1a0f7060b890b95520319101d83ba5aefeb0b1e2fd578b6f72a90758438f04bffbe7536cf112b76297fd47c95e02029fd203c51fb xkeyboard-config-2.34.tar.bz2
+bae6ce7441154b8582cb431256899d748f8f45e24a28898e767e212d1233ea55d52de608ff760f37bb9930e47f1d0d840d085fd4129927e4a1ad3ab446f5b908 xkeyboard-config-xkeyboard-config-2.41.tar.gz
"