aboutsummaryrefslogtreecommitdiffstats
path: root/main/xkeyboard-config/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xkeyboard-config/APKBUILD')
-rw-r--r--main/xkeyboard-config/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/main/xkeyboard-config/APKBUILD b/main/xkeyboard-config/APKBUILD
index 3d72d9af939..740de0bf2c5 100644
--- a/main/xkeyboard-config/APKBUILD
+++ b/main/xkeyboard-config/APKBUILD
@@ -1,29 +1,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xkeyboard-config
-pkgver=2.35.1
+pkgver=2.41
pkgrel=0
pkgdesc="X keyboard configuration files"
-url="https://github.com/freedesktop/xkeyboard-config"
+url="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
arch="noarch"
license="MIT"
-subpackages="$pkgname-doc"
-makedepends="meson perl libxslt"
-source="$pkgname-$pkgver.tar.gz::https://github.com/freedesktop/xkeyboard-config/archive/refs/tags/xkeyboard-config-$pkgver.tar.gz
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends_dev="$pkgname"
+makedepends="gettext meson perl libxslt"
+checkdepends="gawk"
+source="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/-/archive/xkeyboard-config-$pkgver/xkeyboard-config-xkeyboard-config-$pkgver.tar.gz
"
builddir="$srcdir"/xkeyboard-config-xkeyboard-config-$pkgver
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
+
sha512sums="
-2016e126dd807c07cdec045089a83b5b8c2e6eac8255a80c4e5976a0defc7ad55144186457a3109765f3bfb775270296d980366fee3826ee0e3bcd957e60aa5b xkeyboard-config-2.35.1.tar.gz
+bae6ce7441154b8582cb431256899d748f8f45e24a28898e767e212d1233ea55d52de608ff760f37bb9930e47f1d0d840d085fd4129927e4a1ad3ab446f5b908 xkeyboard-config-xkeyboard-config-2.41.tar.gz
"