aboutsummaryrefslogtreecommitdiffstats
path: root/main/xorgproto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xorgproto/APKBUILD')
-rw-r--r--main/xorgproto/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/main/xorgproto/APKBUILD b/main/xorgproto/APKBUILD
index b7387638c6c..774a52188d3 100644
--- a/main/xorgproto/APKBUILD
+++ b/main/xorgproto/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: prspkt <prspkt@protonmail.com>
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=xorgproto
-pkgver=2021.5
+pkgver=2024.1
pkgrel=0
pkgdesc="Combined X.Org X11 protocol headers"
url="https://www.x.org"
@@ -42,14 +42,15 @@ provides="bigreqsproto=$pkgver-r$pkgrel
xineramaproto=$pkgver-r$pkgrel
xproto=$pkgver-r$pkgrel
"
-source="https://xorg.freedesktop.org/archive/individual/proto/xorgproto-$pkgver.tar.bz2"
+source="https://xorg.freedesktop.org/archive/individual/proto/xorgproto-$pkgver.tar.gz"
+options="!check" # no tests
build() {
abuild-meson \
--datadir=/usr/lib \
-Dlegacy=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
@@ -65,5 +66,5 @@ package() {
}
sha512sums="
-0f5c4ee4fd56cd46f4d5850bcf3e04c92d2e98de54d0113987cb49fc83cf1f4d0e50e976333179c72fe2178cfa15ec6c1bfc4e76fc3bc2a4be80616ce079da87 xorgproto-2021.5.tar.bz2
+c2d67a98c5ba9b2f4d0b844c96dab342c497710753a8878b75dbf12ecd64b105c9ee3c5fd11eb91e45960420cf8dd7d02547072a32d5c53e58e009394fe33666 xorgproto-2024.1.tar.gz
"