aboutsummaryrefslogtreecommitdiffstats
path: root/main/yx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/yx/APKBUILD')
-rw-r--r--main/yx/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/yx/APKBUILD b/main/yx/APKBUILD
new file mode 100644
index 00000000000..1e56c84fe6b
--- /dev/null
+++ b/main/yx/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jake Buchholz Göktürk <tomalok@gmail.com>
+# Maintainer: Jake Buchholz Göktürk <tomalok@gmail.com>
+pkgname=yx
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="A small shell tool that allows extraction of targeted data from YAML"
+url="https://gitlab.com/tomalok/yx"
+arch="all"
+license="MIT"
+makedepends="yaml-dev"
+source="
+ yx-$pkgver.tar.gz::https://gitlab.com/tomalok/yx/-/archive/$pkgver/yx-$pkgver.tar.gz
+"
+subpackages="$pkgname-doc::noarch"
+
+build() {
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make install PREFIX="$pkgdir/usr"
+}
+
+sha512sums="
+bc5f990f4a926bfa70a446d4d8d404c6d51dd36a28d0dc893c32b26543b1364470d5f7f37ee69a246716c021e3b33137393aafffca99e5da62aff2ee43af6eeb yx-1.0.2.tar.gz
+"