aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/busybox/APKBUILD8
-rw-r--r--main/busybox/glibc.patch20
2 files changed, 25 insertions, 3 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index b9e679fe155..3203367292f 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.20.2
-pkgrel=3
+pkgrel=4
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -24,7 +24,8 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
0001-ifupdown-pass-interface-device-name-for-ipv6-route-c.patch
0001-ifupdown-use-x-hostname-NAME-with-udhcpc.patch
- busyboxconfig"
+ busyboxconfig
+ glibc.patch"
_sdir="$srcdir"/$pkgname-$pkgver
_staticdir="$srcdir"/build-static
@@ -106,4 +107,5 @@ b0977368029587bab23067f0267ae309 0001-tar-Implement-no-recursion.patch
8c42c9ef0f0419c314c86bcaf7796106 loginutils-sha512.patch
04eeda8c49d4688e6dec02451f8b6aae 0001-ifupdown-pass-interface-device-name-for-ipv6-route-c.patch
e1c183cbe1ca18a0fa0d9597314076c9 0001-ifupdown-use-x-hostname-NAME-with-udhcpc.patch
-8b3bcd5dd5e3245721da3d376172dcac busyboxconfig"
+8b3bcd5dd5e3245721da3d376172dcac busyboxconfig
+befaac2c59c380e36a452b3f1c1d4a3a glibc.patch"
diff --git a/main/busybox/glibc.patch b/main/busybox/glibc.patch
new file mode 100644
index 00000000000..52c9efba1f0
--- /dev/null
+++ b/main/busybox/glibc.patch
@@ -0,0 +1,20 @@
+Fix this by including sys/resource.h.
+
+Signed-off-by: Markus Trippelsdorf <markus at trippelsdorf.de>
+---
+ include/libbb.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/libbb.h b/include/libbb.h
+index f12800f..e7806c2 100644
+--- a/include/libbb.h
++++ b/include/libbb.h
+@@ -40,6 +40,7 @@
+ #include <sys/poll.h>
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
++#include <sys/resource.h>
+ #include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+--