aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/dhcp/APKBUILD5
-rw-r--r--main/dhcp/dhclient-script-fix-bare-ip.patch15
2 files changed, 13 insertions, 7 deletions
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index d1a03bed464..6c6fbd0a329 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -2,7 +2,7 @@
pkgname=dhcp
pkgver=4.4.1
_realver=${pkgver/_p/-P}
-pkgrel=0
+pkgrel=1
pkgdesc="ISC Dynamic Host Configuration Protocol (DHCP)"
url="https://www.isc.org/"
arch="all"
@@ -64,7 +64,6 @@ package() {
dhclient() {
pkgdesc="ISC dhcp client"
- depends="bash"
install -d -o dhcp -g dhcp "$subpkgdir"/var/lib/dhcp
install -d -o dhcp -g dhcp "$subpkgdir"/var/run/dhcp
install -d "$subpkgdir"/usr/sbin
@@ -89,7 +88,7 @@ dhcrelay() {
}
sha512sums="684ae349f224918c9f8cec7bd6c55cd0b83ad2b5827375b2876ca088eb05b7ff1364e50f6dc24f2485c610d9be94d4ba3020f60a0fa0ef63962349d191b887e7 dhcp-4.4.1.tar.gz
-940ba576f9bfb395712e92e59c338428fe30f61da0ea0394f8f677c568322106556281fbb4528a33db7a039963ff892b4d6239aff9377d64927acc26f446c1a6 dhclient-script-fix-bare-ip.patch
+65ddc66553f6f21184dd82baa929f2414b7374e9bafecc22f0d27a653f66796fbcb3a72d2f52af03a6993ce70e1b8dd0ab4fd630824b9a4825799bec190007fb dhclient-script-fix-bare-ip.patch
d5697a56fbbff25199962608986e7ffb533ed4afd3e344e3c79d2010dda73cc0b088f06c454e9f0c69eb054e09a374455fa71d3f73306e0c98fa76df4dd321b7 dhcp-3.0-fix-perms.patch
0c3eee11ee9771a3bd7f8076827e57296136a36e6c00c3149e7274fb7a479feae4dc7d744f3c66ac78ffc96f036e14a7a5a0806095495441f98d76737a34faa6 dhcrelay.initd
fd15dbaa4c61c3c26f407bf13dde859470a1adba134da064b653ccc152ce42635ee8de2fe113ae21ba8470e97e3caad8c1a47b69eb25e5e92b40e26790b96f6d dhcrelay.confd
diff --git a/main/dhcp/dhclient-script-fix-bare-ip.patch b/main/dhcp/dhclient-script-fix-bare-ip.patch
index c325a17fe54..4c8ecc2e4f1 100644
--- a/main/dhcp/dhclient-script-fix-bare-ip.patch
+++ b/main/dhcp/dhclient-script-fix-bare-ip.patch
@@ -1,7 +1,14 @@
-diff -ur a/client/scripts/linux b/client/scripts/linux
---- a/client/scripts/linux 2017-07-25 09:39:54.000000000 -0400
-+++ b/client/scripts/linux 2018-01-23 08:17:42.569366100 -0500
-@@ -345,7 +345,7 @@
+diff --git a/client/scripts/linux b/client/scripts/linux
+index 0c42969..3214eb6 100755
+--- a/client/scripts/linux
++++ b/client/scripts/linux
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ # dhclient-script for Linux. Dan Halbert, March, 1997.
+ # Updated for Linux 2.[12] by Brian J. Murrell, January 1999.
+ # No guarantees about this. I'm a novice at the details of Linux
+@@ -394,7 +394,7 @@ case "$reason" in
make_resolv_conf
else
# flush all IPs from interface