summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/alpine-base/APKBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/main/alpine-base/APKBUILD b/main/alpine-base/APKBUILD
index 33147dfd49d..80f9f0c6af6 100644
--- a/main/alpine-base/APKBUILD
+++ b/main/alpine-base/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-base
pkgver=3.0_beta3
-pkgrel=0
+pkgrel=1
pkgdesc="Meta package for minimal alpine base"
url="http://alpinelinux.org"
arch="noarch"
@@ -30,4 +30,15 @@ Welcome to Alpine Linux ${pkgver%.*}
Kernel \\r on an \\m (\\l)
EOF
+
+ _ver="$(echo "$pkgver" | grep -E -o '^[0-9]+\.[0-9]+')"
+ # create os-release
+ cat >"$pkgdir"/etc/os-release<<EOF
+NAME="Alpine Linux"
+ID=alpine
+VERSION_ID=$pkgver
+PRETTY_NAME="Alpine Linux v$_ver"
+HOME_URL="http://alpinelinux.org"
+BUG_REPORT_URL="http://bugs.alpinelinux.org"
+EOF
}