aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/multipath-tools/0001-Disable-Werror-and-O2.patch27
-rw-r--r--main/multipath-tools/0001-OPTFLAGS-patch.patch26
-rw-r--r--main/multipath-tools/APKBUILD17
-rw-r--r--main/multipath-tools/json-c-0.14.patch23
4 files changed, 34 insertions, 59 deletions
diff --git a/main/multipath-tools/0001-Disable-Werror-and-O2.patch b/main/multipath-tools/0001-Disable-Werror-and-O2.patch
new file mode 100644
index 00000000000..a34f71b12ce
--- /dev/null
+++ b/main/multipath-tools/0001-Disable-Werror-and-O2.patch
@@ -0,0 +1,27 @@
+From c52875c963eade8c7c10d06a9e5d6dd53e60e518 Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Mon, 16 Nov 2020 09:27:56 +0000
+Subject: [PATCH] Disable Werror and O2
+
+---
+ Makefile.inc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.inc b/Makefile.inc
+index e05f3a9..d523e6f 100644
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -93,8 +93,8 @@ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
+ ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
+ WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered -Wno-error=clobbered,)
+
+-OPTFLAGS := -O2 -g $(STACKPROT) --param=ssp-buffer-size=4
+-WARNFLAGS := -Werror -Wall -Wextra -Wformat=2 -Werror=implicit-int \
++OPTFLAGS := -g $(STACKPROT) --param=ssp-buffer-size=4
++WARNFLAGS := -Wall -Wextra -Wformat=2 -Werror=implicit-int \
+ -Werror=implicit-function-declaration -Werror=format-security \
+ $(WNOCLOBBERED) -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS)
+ CPPFLAGS := -Wp,-D_FORTIFY_SOURCE=2
+--
+2.28.0
+
diff --git a/main/multipath-tools/0001-OPTFLAGS-patch.patch b/main/multipath-tools/0001-OPTFLAGS-patch.patch
deleted file mode 100644
index 0e7e0db06c5..00000000000
--- a/main/multipath-tools/0001-OPTFLAGS-patch.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From c42ef66d93ad183a832c9c62a4c909a4cff27358 Mon Sep 17 00:00:00 2001
-From: Leonardo Arena <rnalrd@alpinelinux.org>
-Date: Thu, 7 May 2020 07:39:30 +0000
-Subject: [PATCH] OPTFLAGS patch
-
-Remove Werror and O2
----
- Makefile.inc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile.inc b/Makefile.inc
-index d4d1e0d..fa39f25 100644
---- a/Makefile.inc
-+++ b/Makefile.inc
-@@ -93,7 +93,7 @@ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
- ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
- WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered,)
-
--OPTFLAGS = -O2 -g -pipe -Werror -Wall -Wextra -Wformat=2 -Werror=implicit-int \
-+OPTFLAGS = -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
- -Werror=implicit-function-declaration -Werror=format-security \
- $(WNOCLOBBERED) \
- -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS) \
---
-2.26.0
-
diff --git a/main/multipath-tools/APKBUILD b/main/multipath-tools/APKBUILD
index d0bb47217d6..2902e62137b 100644
--- a/main/multipath-tools/APKBUILD
+++ b/main/multipath-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=multipath-tools
-pkgver=0.8.4
-pkgrel=2
+pkgver=0.8.5
+pkgrel=0
pkgdesc="Device Mapper Multipathing Driver"
url="http://christophe.varoqui.free.fr"
arch="all"
@@ -11,12 +11,10 @@ makedepends="lvm2-dev libaio-dev readline-dev ncurses-dev eudev-dev
userspace-rcu-dev json-c-dev perl"
subpackages="$pkgname-doc $pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=snapshot;h=$pkgver;sf=tgz
- json-c-0.14.patch
multipath-tools.conf
multipath.initd
multipathd.initd
-
- 0001-OPTFLAGS-patch.patch
+ 0001-Disable-Werror-and-O2.patch
"
options="!check"
@@ -43,15 +41,14 @@ package() {
"$pkgdir"/etc/init.d/multipathd
install -D -m755 "$srcdir"/multipath.initd \
"$pkgdir"/etc/init.d/multipath
- install -D -m644 README \
- "$pkgdir"/usr/share/doc/$pkgname/README
+ install -D -m644 README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/README.md
install -D -m644 README.alua \
"$pkgdir"/usr/share/doc/$pkgname/README.alua
}
-sha512sums="720823188c053c1c50269a30e34a9d69099098495bfd607076bcfa2c079565e3f0580c91783f19d42ed82290c0db98e4e19ef620eca4ee5ec7885c49c72d2307 multipath-tools-0.8.4.tar.gz
-fae0e1fbc7dfe6d932a5b19e9a80efdc30a2bad3ac4e24ff2f8ec9b156107378b5f15d4bec8c32dbfd87286cd7e30b4acebfadda416365f108dafeea0321318a json-c-0.14.patch
+sha512sums="f62a09107ccb18ffab97139fe2dba3dc22450836d8669c4381a8bce4072672a027a3a1e687f33e374429bffa49b3ba4a54d1e52294044d7bc1f82ed5d5aaf760 multipath-tools-0.8.5.tar.gz
e81462b22c0cbc92ea935d7544b9f9a0c4ccbcf13f3bc03dadf6de96407c9cf49964c9bbf02f12a134e1255c66421c6fde39d54b15eef975e8df81bdc88b2213 multipath-tools.conf
97deeee57daee787d807da0a4dbf50baae047ddcda30925f7000ec822b5a17a3dc55196c3e032c8ffbc2caeac690ce5ca485b0a7c99f15e66bddaa000439112a multipath.initd
2f913fed199f12f048eb042b5bb1a326f6f09cfe63d572ac269461d96ebf25b251576de22be7ba9ab631ded7af6fd47dac38fda3b29d00640c806181eb37447c multipathd.initd
-909054c95bd2ee6a2651ad2849c4308342ba17c05ce557dc751c0ce3efc8a10f733cb6efa25d07b1f519858c05dadaf6622fac6e233a02cfedf53f99f28065d9 0001-OPTFLAGS-patch.patch"
+6dacba3833ab0f0bb6b8ba4d1a1fd8e7745b01ea22661f16fb654882c9b68db4b4cd6642ecbd77e37d913903eade9baf5185d4d6d454ccd00d5c0f16b3bba0d2 0001-Disable-Werror-and-O2.patch"
diff --git a/main/multipath-tools/json-c-0.14.patch b/main/multipath-tools/json-c-0.14.patch
deleted file mode 100644
index f827fdf1549..00000000000
--- a/main/multipath-tools/json-c-0.14.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/libdmmp/libdmmp_private.h b/libdmmp/libdmmp_private.h
-index 3e813cb..9c89acb 100644
---- a/libdmmp/libdmmp_private.h
-+++ b/libdmmp/libdmmp_private.h
-@@ -82,7 +82,7 @@ static out_type func_name(struct dmmp_context *ctx, const char *var_name) { \
- do { \
- json_type j_type = json_type_null; \
- json_object *j_obj_tmp = NULL; \
-- if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != TRUE) { \
-+ if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != 1) { \
- _error(ctx, "Invalid JSON output from multipathd IPC: " \
- "key '%s' not found", key); \
- rc = DMMP_ERR_IPC_ERROR; \
-
-@@ -90,7 +90,7 @@ do { \
- } \
- if (j_obj_tmp == NULL) { \
- _error(ctx, "BUG: Got NULL j_obj_tmp from " \
-- "json_object_object_get_ex() while it return TRUE"); \
-+ "json_object_object_get_ex() while it return 1"); \
- rc = DMMP_ERR_BUG; \
- goto out; \
- } \