aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/py-sphinx_rtd_theme/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/main/py-sphinx_rtd_theme/APKBUILD b/main/py-sphinx_rtd_theme/APKBUILD
index 32ac3b1bc44..9ae6cda0639 100644
--- a/main/py-sphinx_rtd_theme/APKBUILD
+++ b/main/py-sphinx_rtd_theme/APKBUILD
@@ -2,22 +2,28 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-sphinx_rtd_theme
_pkgname=sphinx_rtd_theme
-pkgver=0.2.4
+pkgver=0.4.0
pkgrel=0
pkgdesc="Sphinx theme for readthedocs.org"
url="https://github.com/snide/sphinx_rtd_theme"
arch="noarch"
license="MIT"
-depends=""
makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="pytest"
+options="!check" # readthedocs_ext is missing
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$_pkgname-$pkgver.tar.gz::https://github.com/snide/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ py.test
}
package() {
@@ -43,4 +49,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="05ad2ce1fbf395399d996f0b25dc170dda1b51c2fecbd937685b6364e27071b204d26edb8caff29ba2232eaa41b39f8c2e36566e5bc888f6e5537d7fc2bc168f sphinx_rtd_theme-0.2.4.tar.gz"
+sha512sums="c54050b0e6f05d664ec1b7f65e5f4f93181f535b345ba91ff9ada73dfd1b9c4e1d549f7a159131e99332beab6914fb00f81d66a72fe69b3f1dfe78abee539ebe sphinx_rtd_theme-0.4.0.tar.gz"