aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/e2fsprogs/APKBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/main/e2fsprogs/APKBUILD b/main/e2fsprogs/APKBUILD
index 572cecd8c64..46744cc2ae1 100644
--- a/main/e2fsprogs/APKBUILD
+++ b/main/e2fsprogs/APKBUILD
@@ -7,17 +7,16 @@ pkgdesc="Standard Ext2/3/4 filesystem utilities"
url="http://e2fsprogs.sourceforge.net"
arch="all"
license="GPL-2.0-or-later LGPL-2.0 BSD-3-Clause MIT"
-depends=""
depends_dev="util-linux-dev"
-options="!check"
makedepends="$depends_dev linux-headers"
+checkdepends="diffutils perl"
subpackages="$pkgname-dev $pkgname-doc libcom_err $pkgname-libs $pkgname-extra"
source="https://www.kernel.org/pub/linux/kernel/people/tytso/$pkgname/v$pkgver/$pkgname-$pkgver.tar.xz
gnuc-prereq.patch
"
builddir="$srcdir/$pkgname-$pkgver"
-build () {
+build() {
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -33,6 +32,18 @@ build () {
make
}
+check() {
+ cd "$builddir"
+
+ # Disable failing test
+ rm -rf tests/m_offset*
+
+ # Failing on CI
+ rm -rf tests/f_bigalloc_orphan_list*
+
+ make check
+}
+
package() {
cd "$builddir"
make -j1 MKDIR_P="install -d" DESTDIR="$pkgdir" install install-libs