aboutsummaryrefslogtreecommitdiffstats
path: root/testing/amsynth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/amsynth/APKBUILD')
-rw-r--r--testing/amsynth/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/amsynth/APKBUILD b/testing/amsynth/APKBUILD
new file mode 100644
index 00000000000..4b527329244
--- /dev/null
+++ b/testing/amsynth/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=amsynth
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="easy-to-use software synth with a classic subtractive synthesizer topology"
+url="https://amsynth.github.io"
+arch="all"
+license="GPL-2.0-only"
+depends="libintl"
+makedepends="alsa-lib-dev gettext-dev gtk+2.0-dev jack-dev lv2-dev"
+subpackages="$pkgname-lang $pkgname-lv2"
+source="https://github.com/amsynth/amsynth/releases/download/release-1.10.0/amsynth-$pkgver.tar.gz"
+
+build() {
+ LDFLAGS="-lintl $LDFLAGS"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+lv2() {
+ pkgdesc="amsynth (LV2 plugins)"
+ amove usr/lib/lv2/*
+}
+
+sha512sums="36252256f436f986336375f75f18a9381ab9616570d1a52ae575865b7c1bb9dec231e11358775055a9ef2348e5c8a3e059419a7fd6f8e27f6e269a345df4f83f amsynth-1.10.0.tar.gz"