aboutsummaryrefslogtreecommitdiffstats
path: root/testing/amule/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/amule/APKBUILD')
-rw-r--r--testing/amule/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/testing/amule/APKBUILD b/testing/amule/APKBUILD
index a83aebb290f..6fee968f6ee 100644
--- a/testing/amule/APKBUILD
+++ b/testing/amule/APKBUILD
@@ -3,30 +3,39 @@
pkgname=amule
_pkgname=aMule
pkgver=2.3.3
-pkgrel=5
+pkgrel=13
pkgdesc="eMule-like client for the eD2k and Kademlia networks"
url="https://www.amule.org/"
-arch="all"
+arch="all !x86" # crypto++
license="GPL-2.0-or-later"
-makedepends="bison boost-dev crypto++-dev gd-dev geoip-dev libsm-dev libupnp-dev
- wxgtk3-dev"
+makedepends="
+ bison
+ boost-dev
+ crypto++-dev
+ gd-dev
+ geoip-dev
+ libsm-dev
+ libupnp-dev
+ wxwidgets-dev
+ "
options="!check" # unexpected end of file
subpackages="$pkgname-lang $pkgname-doc"
-source="$_pkgname-$pkgver.tar.xz::https://downloads.sourceforge.net/project/amule/aMule/2.3.3/aMule-$pkgver.tar.xz
+source="$_pkgname-$pkgver.tar.xz::https://downloads.sourceforge.net/project/amule/aMule/$pkgver/aMule-$pkgver.tar.xz
fix-gcc11-include.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
+ export CFLAGS="$CFLAGS -flto=auto -DNDEBUG"
+ export CXXFLAGS="$CXXFLAGS -flto=auto -DNDEBUG"
+
./configure \
- CPPFLAGS="$CPPFLAGS -Wno-unused-local-typedefs" \
- CFLAGS="$CFLAGS -fPIC" \
- CXXFLAGS="$CXXFLAGS -fPIC" \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
+ --disable-debug \
--enable-alc \
--enable-alcc \
--enable-amule-daemon \
@@ -37,9 +46,9 @@ build() {
--enable-optimize \
--enable-upnp \
--enable-webserver \
- --disable-debug \
- --with-boost \
- --with-wx-config=wx-config-gtk3
+ --enable-fileview \
+ --with-boost
+
make
}