aboutsummaryrefslogtreecommitdiffstats
path: root/testing/antibody/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/antibody/APKBUILD')
-rw-r--r--testing/antibody/APKBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/testing/antibody/APKBUILD b/testing/antibody/APKBUILD
index 4d127d5b5be..520869fd59f 100644
--- a/testing/antibody/APKBUILD
+++ b/testing/antibody/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Aleks Bunin <alpinelinux@compuix.com>
pkgname=antibody
pkgver=6.1.1
-pkgrel=1
+pkgrel=20
pkgdesc="The fastest zsh shell plugin manager."
url="https://github.com/getantibody/antibody"
license="MIT"
@@ -10,16 +10,14 @@ arch="all"
depends="git zsh"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/getantibody/antibody/archive/v$pkgver.tar.gz"
-builddir="$srcdir/go/src/github.com/getantibody/antibody"
+options="!check" # uses removed github api
-prepare() {
- default_prepare
- mkdir -p "$srcdir/go/src/github.com/getantibody"
- mv "$srcdir/$pkgname-$pkgver" "$builddir"
-}
+export GOFLAGS="$GOFLAGS -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- export GOPATH="$srcdir/go"
go build -o antibody -ldflags "-X main.version=$pkgver" -trimpath
}
@@ -31,9 +29,6 @@ package() {
install -sD -m 755 antibody "$pkgdir"/usr/bin/antibody
}
-cleanup_srcdir() {
- go clean -modcache
- default_cleanup_srcdir
-}
-
-sha512sums="0a436227d195b1e68be03d62d0f7fab0f10c4434df10e047468809a6dcf330623c54ddf4e52c459d7b816a3be977e62c6aba58408881f9a45583456e37614b04 antibody-6.1.1.tar.gz"
+sha512sums="
+0a436227d195b1e68be03d62d0f7fab0f10c4434df10e047468809a6dcf330623c54ddf4e52c459d7b816a3be977e62c6aba58408881f9a45583456e37614b04 antibody-6.1.1.tar.gz
+"