aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache-mod-auth-openidc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apache-mod-auth-openidc/APKBUILD')
-rw-r--r--testing/apache-mod-auth-openidc/APKBUILD31
1 files changed, 24 insertions, 7 deletions
diff --git a/testing/apache-mod-auth-openidc/APKBUILD b/testing/apache-mod-auth-openidc/APKBUILD
index b2309898622..11eb98866b0 100644
--- a/testing/apache-mod-auth-openidc/APKBUILD
+++ b/testing/apache-mod-auth-openidc/APKBUILD
@@ -1,18 +1,33 @@
# Maintainer: Takumi Takahashi <takumiiinn@gmail.com>
pkgname=apache-mod-auth-openidc
_pkgname=mod_auth_openidc
-pkgver=2.4.4.1
+pkgver=2.4.15.7
pkgrel=0
pkgdesc="OpenID Connect Relying Party implementation for Apache HTTP Server 2.x"
url="https://www.mod-auth-openidc.org"
-arch="all !s390x !mips !mips64" # tests fails on s390x from cjose
+arch="all !s390x" # tests fails on s390x from cjose
license="Apache-2.0"
depends="apache2"
-makedepends="apache2-dev musl-dev cjose-dev openssl-dev curl-dev hiredis-dev jansson-dev jq-dev pcre-dev oniguruma-dev"
+makedepends="
+ apache2-dev
+ cjose-dev
+ curl-dev
+ hiredis-dev
+ jansson-dev
+ jq-dev
+ musl-dev
+ oniguruma-dev
+ openssl-dev
+ pcre2-dev
+ "
subpackages="$pkgname-doc $pkgname-static"
-source="https://github.com/zmartzone/mod_auth_openidc/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz"
+source="https://github.com/OpenIDC/mod_auth_openidc/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+# secfixes:
+# 2.4.15.3-r0:
+# - CVE-2024-24814
+
build() {
./configure \
--build=$CBUILD \
@@ -28,8 +43,8 @@ check() {
package() {
mkdir -p "$pkgdir"/usr/lib/apache2
- /usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/build-1/libtool' src/mod_auth_openidc.la "$pkgdir"/usr/lib/apache2
- /usr/share/build-1/libtool --mode=install install src/mod_auth_openidc.la "$pkgdir"/usr/lib/apache2
+ /usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/build-1/libtool' mod_auth_openidc.la "$pkgdir"/usr/lib/apache2
+ /usr/share/build-1/libtool --mode=install install mod_auth_openidc.la "$pkgdir"/usr/lib/apache2
mkdir -p "$pkgdir"/etc/apache2/conf.d
cat <<- __EOF__ > "$pkgdir"/etc/apache2/conf.d/mod-auth-openidc.conf
@@ -41,4 +56,6 @@ package() {
install -Dm644 README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
}
-sha512sums="fd551ba709221cbe20d1ed3eb80023a03b8d9e793f41cdfc6ab8e0cc165a3580632c31035a6cd43950b20e16b3da941d8f8e9c7f6b580c89b82f02ccb42d7e92 mod_auth_openidc-2.4.4.1.tar.gz"
+sha512sums="
+cf32be4eaf5df9000af760bc1ef2fe372110fb385c4fc216724563eb71593a765a533acbf5210fd0686a58eab606bd362c8f1514c2f179906a502b25556a14b6 mod_auth_openidc-2.4.15.7.tar.gz
+"