aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apmpkg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apmpkg/APKBUILD')
-rw-r--r--testing/apmpkg/APKBUILD41
1 files changed, 32 insertions, 9 deletions
diff --git a/testing/apmpkg/APKBUILD b/testing/apmpkg/APKBUILD
index cecbe409354..734d0214c8e 100644
--- a/testing/apmpkg/APKBUILD
+++ b/testing/apmpkg/APKBUILD
@@ -1,19 +1,29 @@
# Contributor: kedap <kedap.dev@protonmail.com>
# Maintainer: kedap <kedap.dev@protonmail.com>
pkgname=apmpkg
-pkgver=1.4.0
-pkgrel=0
+pkgver=1.5.1
+pkgrel=3
pkgdesc="A Package Manager as a model: PKGBUILD"
url="https://github.com/kedap/apmpkg"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
+# armhf: test timeout
+# s390x, riscv64: limited by rust/cargo
+arch="all !s390x !armhf !riscv64"
license="Apache-2.0"
-depends="git fakeroot wget ruby-bundler py3-pip rsync bash ruby-dev"
-makedepends="cargo openssl-dev"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Kedap/apmpkg/archive/refs/tags/$pkgver.tar.gz"
+depends="git fakeroot wget ruby-bundler py3-pip bash ruby-dev npm"
+makedepends="cargo openssl-dev>3 patchutils cargo-auditable"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-zsh-completion
+ $pkgname-fish-completion
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/Kedap/apmpkg/archive/refs/tags/$pkgver.tar.gz
+ fix-with-outdated-rust.patch
+ "
+
build() {
- cargo build --release --locked --verbose
+ cargo auditable build --release --locked --verbose
}
check() {
@@ -28,8 +38,21 @@ package() {
#Install documentation
install -Dm0644 man/*.1 -t "$pkgdir"/usr/share/man/man1
+
+ #Install bash completion
+ install -Dm0644 completions/$pkgname.bash-completion \
+ "$pkgdir"/usr/share/bash-completion/completions/$pkgname
+
+ #Install zsh completion
+ install -Dm0644 completions/_$pkgname \
+ "$pkgdir"/usr/share/zsh/site-functions/_$pkgname
+
+ #Install fish completion
+ install -Dm0644 completions/$pkgname.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/$pkgname.fish
}
sha512sums="
-b3ba5394b48d2b834ab7e727b4505ef85a885d7a174bcd507e9a139c8cdcf4e9e179ff94c170822290188839884eb6c3e992d8bff7eaab407c3555b1e290736e apmpkg-1.4.0.tar.gz
+20190348ab2a2d12b2647dcdd017e6fb739b3cf2c3eb559b15d0ce7058d38fd9bccd3bc4385707594e0bebb551d746df6a646f94d079d5b92f7a8c366a350c61 apmpkg-1.5.1.tar.gz
+31c7b35f4bd114d3ccae4bffe5e0bcdb4a477f1803206ba771dcfc212a03df741387abbd110a407e6f057aedfa620c694898875b9be52388fced8aa360a09fef fix-with-outdated-rust.patch
"